Stuck in ‘Press Any Key to Start’ - Still!

Please tag your post with #pc and/or #xbox. #self-service:pc-hardware

Are you on Steam or Microsoft Store version? Microsoft

Are you using Developer Mode or made changes in it? No

Dear Microsoft and Asobo,

I’m feeling extremely frustrated as I am still experiencing intermittent stuck in “press start” mode. I’ve spent countless amount of my time (I.e. hours) and applied some of the suggestions, rebooted the computer, then restarted MSFS2020 to get this to work, but with NO success.

In all my time playing some PC games, including all versions of Microsoft flight simulator, I have NEVER encountered continual problems just to start up a game. Come on Microsoft, this is ridiculous!! You cannot call your game “The game of the year” then ask your loyal paying customers to spend their time just to get the game to load up. Unacceptable!!

Is it too much to ask that when I double click on the game icon, that it will load up the first time, every time??

I’m on the latest version of MSFS2020, and have tried the suggested methods to resolve i.e. move all files from the community folder before starting. I have deleted the rolling cache as well (multiple times) and no longer have this selected.

Sometimes I’m able to get into the Sim as it gives me the option to start the Sim in ‘safe mode’. This happens when I close the Sim via the TaskManager. But the next day I come back to starting up the Sim, the same problem happens!

I also have the PC Xbox app installed and logged in to my account. All programs were installed using ‘Admin’ mode.

Please Microsoft… fix this basic problem for all of us.

Does anyone have any further suggestions?

Note : I also tried upgrading to Windows 11…… what an absolute waste of time! The program would not recognise my Nvidia video card and defaulted to the inboard ■■■■■■ graphics card. Lucky I was in the 10 day grace window period and I rolled back to windows 10.

PC :
Store Version : Flight Simulator Version
i7-9750H Processor 2.6 GHz
NVIDIA GeForce GTX 1660Ti 6GB, Driver Vers 497.29
Windows 10 up to date, 64-bit

I get the same issue regularly in recent months. Says ‘Press any key to start’, then ‘sign in to Xbox’ screen, then a continual loop between the two. Seems to happen if any of the following have an update: Store, Gaming services, Xbox app, MSFS2020.

One of the below usually works eventually, but solution seems at random each time…

First time I had issue, US Language Pack needed installing. The next time seemed to be because I have two Windows accounts on laptop and it worked after logging out of the other account and then running the fixes. More recently, clearing the Windows Store cache worked. Then, the next time, reinstalling Gaming Services. And this time, logging out of Xbox app, deleting app and reinstalling. It would seem you have to follow the reboot advice whenever the instructions demand it, don’t skip that bit.

All very frustrating…

Ok thanks for posting those links. I’ll give them a go and see how it goes.

There just seems to be too many ways to temporarily fix the issue, which is not great for the end user.


1 Like


We want to make these forums a positive environment for you to discuss Microsoft Flight Simulator related topics, and to give us your feedback on the sim.

Non-constructive posts do not provide meaningful information that helps in the development of the simulator. We value constructive criticism about MSFS as it helps the developers further understand, triage and resolve problems within MSFS.

Take the following example posts:

The ATC in this simulator is ■■■■

ATC’s altitude instructions are awful. I was on a flight from KSFO to KDEN in an A320N, when ATC cleared me for descent below the minimum safe altitude. If I stayed at a safe altitude it would cancel my IFR clearance and my approach, so I followed their instructions leading to a crash on the side of a mountain.

ATC needs to take the terrain into account when issuing clearances!

The non-constructive example (top) provides no meaningful information, no one will be able to understand, reproduce or document the issue, and therefore the issue cannot be resolved.

We ask that you consider this going forward. We continue to welcome criticism and complaints so long as they are constructive in nature and inline with the Code of Conduct on the forum.

Thank you for your understanding.

1 Like

Thank you for the lesson in Code of Conduct.

There was no abuse or offensive comments in my post. Just the plain factual truth that many people feel about this “pay now, fix problems later” attitude of the global software industry.

Having said that, I’m always in absolute awe of how much work goes into creating these games, especially this one.

I have the same problem to enter MSFS via XBox now and sometimes in the past
When I press the first photo, I go to the second photo, but if I press any button, I return to the first photo; and so on. But I can not enter MSFS.

I was all the day yesterday that I could not enter MSFS via XBox; today, without doing nothing, It has fixed alone. But it is very annoying that sometimes happens the same problem since you enter MSFS via XBox. Is important that Microsoft, XBox or Asobo take note of it and fix it at once.

Probably internet problems but who’s I can’t say