Stuck on 1.21.18

Please tag your post with #pc and/or #xbox.

Are you on Steam or Microsoft Store version?

Are you using Developer Mode or made changes in it?

Brief description of the issue:
Updated MS Windows, went to MS Store, nothing to download. I launch MSFS, it goes to the “checking for updates” page, nothing, moves right along to the Sim. I can see in the Marketplace that there is a new WU to download, but I am still on 1.21.18, so I can’t download the content.

I’ve tried restarting the PC and I have updated Windows. Empty community folder.

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:

PC specs and/or peripheral set up of relevant:

Build Version # when you first started experiencing this issue:

Have you checked on your Xbox App on your PC? Usually the sim needs to be updated from the Xbox App, not the Microsoft Store.

Same here. I did this:

  1. Updated windows

  2. Checked MS store app

  3. Checked Xbox app

  4. Started FS, no update detected (can’t get world update from market as 1.21.18 isn’t compatible)

  5. Quit FS and logged out of xbox

  6. Logged back in to xbox, but still no option to update:

  7. Rebooted again for giggles

  8. Repeated steps 1-7 above

The loop doesn’t end for me.

PS, I don’t hate MS or Asobo either. I’m patient and everything will get worked out like it always does. :slight_smile:

Yeah but I’ll try it again.

Did you get it figured out?

1 Like

I got it finally. I had to use powershell and clear the MS app store cache and then reinstall gaming services, and then xbox recognized that it needed an update.

Same here. No update available anywhere (MS Store/XBox App). MSFS just starts normally. Tried everything except a complete reinstall. Had similar problems before, but it never was that obstinate.

Be glad if you’re stuck on 1.21.18. Random CTDs are back with 1.22.

May I ask for the commands to use powershell to clear the cache?

I have a laptop that rarely offers to update FS.

I did uninstall and reinstall, wasting many hours.

Yep. See this link:

Microsoft Store - Download and Installation issues - Basic Troubleshooting – Microsoft Flight Simulator Support (
Then specifically this part:

and this part:

Thank you!