Stuck on black screen with loading circle in bottom right corner (not spinning)

Hello!
I hadn’t played MSFS for a long time but with the new performance update i really wanted to play again. I have the microsoft store version for windows. When i booted up the game i had to go to the store to install an update. after that the game would not load and got the the black screen pictured below, so i uninstalled it thinking a reinstall would fix the game. I was able to uninstall and reinstall the game but i cannot get to the point where you download the huge amount of data files for the game. most of the time i get to the black screen pictured below, occasionally i get a bit further to the white xbox game studios screen (i cant post 2 images because of forum rules). in all cases the program hangs and does not progress (also the white circle does not spin on the black screen). I have tried disabling all my sound devices, completely disabling my firewalls and other virus protection, updating my gpu drivers and launching the game from geforce experience, the store and my desktop. Any help would be appreciated!

specs:
2080 super
2700x
16 gigs 3200 mhz ram
(can’t remember the model of my motherboard)

Hi there, I have exactly the same issue. The loading circle spins twice and then the simulator crashes…system is up to date and I never had any problems like this before.

Specs:
Intel(R) Core™ i7-9700K CPU @ 3.60GHz 3.60 GHz
RAM: 32 GB, 64-bits, GeForce 1080Ti 11 GB

glad to see it is not just me :stuck_out_tongue: can you submit a ticket so maybe they will fix it? I also tried buying the game on steam and had the same problem

2 Likes

Got the same issue and reinstalled latest Nvidia drivers without installing Geforce Experience.

Got it to load but I am now stuck on the Checking for update screen… But at least the circle is spinning…

did nothing for me :frowning:

I had this too.
Try out the FlightSimulator.exe as an Administrator.
This is how it works for me.
Good luck !

Same here - black window opens, blue circle starts spinning, CTD. Have already deinstalled and tried to reinstall - same problem. Run as admin didn’t help as well

1 Like

the hotfix fixed this issue for me XD

I have this issue even with the hot fix. The sim stuck on the black screen with the circle and doesn’t launch.
Everything was fine before the SU5

Same here - still stuck with the black window and then CTD! No changes after hotfix. Have already reinstalled a couple of times incl. deleting remaining folders.

All you can do is contact support. GL

I have tried to run FlightSimulator.exe as an Admin…getting the message saying: “I don’t have access to the apparat, path or file. Possible I don’t have enough rights to access this item”. I have checked in MS Store, both the digital ownership and the MSFS2020 Premium Deluxe are there up to date and installed. It seems like every time I am accessing the MS Store FS2020 the Store is crashing…I have reinstalled the Store and the game but still the same problem.

I guess I have found the solution:

I have removed Asus Sonic Studio 2 and the FS2020 is lunching normally.

More info here: https://flightsimulator.zendesk.com/hc/en-us/articles/360015999539