Stuck on „Checking for Updates“ when more than 446 packages (parts of add-ons) installed (XBox)

:wave: Thank you for using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?


Have you disabled/removed all your mods and addons?


Brief description of the issue:

When 446 packages (228 add-ons with 446 packages in my case) are installed, startup works fine. If I add a single package more, like a single livery of the „103 Solo“ or an add-on that consists of only one package, startup gets stuck on „Checking for Updates“. I have varied the order of installation and every add-on has been installed and working one time or another, but as soon as the total number of packages exceeds 446, the startup gets stuck.

Detailed steps to reproduce the issue encountered:

Startup was working with 189 add-ons. I started adding add-ons one at a time, restarting MSFS after each installation to see if the startup still works. I got to 228 add-ons, 446 packages, 247.16 GB used space with the startup still working. Afterwards I did the following experiments.

Added „Top Rudder 103 Solo“ (10 packages)
229 add-ons, 456 packages, 247.46 GB
STUCK on „Checking for Updates“

Removed 5 liveries of „103 Solo“ using „cloud gaming trick“
451 packages

Removed „103 Solo“ completely
446 packages again
Startup working

Removed Savoia Marchetti (6 packages)
227 add-ons, 440 packages
Startup working

Added „Top Rudder 103 Solo“ again (10 packages)
450 packages
STUCK at „Checking for Updates“

Removed 4 liveries of „103 Solo“ using „cloud gaming trick“ again
446 packages
Startup working

I actually did more experiments, also with the Dornier DO-J, but every time I went beyond 446 packages, it stopped working. I didn‘t have this issue before SU12. If I stay below the limit the sim works fine. I had just one CTD since the SU12 update and I really appreciate all the work.

PC specs and/or peripheral set up if relevant:

XBox Series X

Build Version # when you first started experiencing this issue:

SU12, all updates installed (worked with SU11)

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Hi there,

Does your issue sound similar to this one on Xbox?

EDIT: I saw your response here, disregard. Xbox problems with memory / content after Sim Update 12 - #39 by RimcaHiwao

1 Like

I have a similar issue on a MSFS PC installation. Currently I have 458GB of Marketplace Content in my localCache/packages/official drawer. If I install one maschine e.g sws zlin in addition my flightsim does endless loop on the Upgrade Page. After deleting the latest installed file from the official drawer the MSFS starts normaly.

Thank you. Could you post the number of add-ons and packages (parts of add-ons) in your folder? The size in GB doesn‘t seem to be triggering the problem in my case, although there are reports about a 500 GB size limit on XBox. The size of my reserved space is just about 260 GB.

In case somebody wonders. The „cloud gaming trick“ is, that when you uninstall an add-on or just a package (part of add-on) in a cloud gaming session, it will be remove on your XBox as well next time during startup, apparently before the update check. This helps me right now to „repair“ a broken MSFS installation by removing add-ons to get below a total of 446 installed packages. This works reliably so far and allows for some experimenting without having to delete the entire reserved space once startup is broken. It saves a lot of download time.

Cloud Gaming… that makes me wonder if its introduction is what is responsible for this:

Deleting Marketplace Content on One Installation, Automatically Deletes it on All Installations - Bug Reports & Wishlist / Install, Performance & Graphics - Microsoft Flight Simulator Forums

Hi I currently have 981 Elements in the onestore folder, if I install Zenith CH701 by Simworks Studios I get that endless Sim Update Situation. My MSFS does not start anymore. After deleting the installed file from the ONESTORE Drawer msfs starts up normal again.

Could be. I just hope that problem won‘t be fixed right now, since it allows me to „fix“ my XBox fairly quickly. :slight_smile: Downloading the entire reserved space again takes half a day. Next Tuesday I will see how many add-ons I have to delete in order to install WU13 and still have a working system.

1 Like

How do you play from the cloud? I see no option to do so on my sim for Xbox

This seems to be related to After SU12 stuck on searching for updates with more than 1025 Items in OneStore Folder can everyone vote in both please.


Yes, everybody should vote on all related topics and I did. :slight_smile: However I am afraid the number of people, actually having enough add-ons to run into this problem, is still small.

1 Like

You need Gamepass Ultimate for access to cloud gaming and then you need a support device, like an iPad or even better a PC with windows. You are right, you cannot start MSFS on the XBox in the cloud or maybe you can if isn’t actually installed. However that would not be useful for us here.

The performance of the system, you are using, doesn‘t really matter as long as your network connection is reasonably fast and stable. It works for me with an old laptop, Windows 11 and 16 MBit/s network connection. An iPad works for me as well.


With enough world updates that number will eventually explode. :slight_smile:

I just installed WU13 and I also got the ATR, because I am an optimist and hopeful the „Checking for Updates“ problem will be fixed (soon). The new releases are amazing, as far as I can tell from videos and screenshots, because unfortunately I could not try them myself yet.

WU13 consists of 26 packages. So I removed 25 to install it and to end up with 447 installed packages in to total. I thought I give it a try after the MSFS XBox update and see if I can push the limit. It did not work. The sim got stuck at startup. Then I continued as follows:

Removed 1 package (using cloud)
446 packages (?)
STUCK at „Checking for Updates“

Removed 1 package (using cloud)
445 packages (?)

Removed more packages
436 packages
Startup working

Installed 10 packages again to get to old working limit

Removed 2 liveries
Startup working

Added 1 livery pacakge

Removed 1 livery
Startup working

So 444 seems to be the new limit on my XBox. Right now I have 116 packages that are not installed. I will remove most of the bush trips and discovery flights again to have some safety buffer, but that is really a pity, I like those.

The „space used“ shown in content manager is 259,20 GB.

I think this is really a problem with the network communicaton for the update check. I kind of assume that since SU12 the check happens in a single request, which of course gets bigger with the number of packages installed. If that is the case, perhaps the requests are running into a (configured) size limit on the server and that problem is not handled properly by the server code. The update check is probably the single biggest query going from the sim to the server. There are usually no limits on downloads, but incoming requests often have limits. Maybe we are even triggering some DoS protection mechanism. This is of course all speculation, since I don‘t have any insights into how MSFS and its servers are implemented, but these kinds of problems happen and often they don‘t show up in testing environments used by developers to test their code.

I have no idea why the limit would go down from 446 to 444 after the latest update.

Anyway, thanks for all the work. I hope the testing helps. I am looking forward to a time when I can just fly instead of spending hours managing/fixing my installation. After all „THE SKY IS CALLING“. :smiley:

I still have the same issue as you on my PC. I have
1009 Items in my onestore folder
46 in my community folder

I add one item more I have the “checking for Updates” endless screen again.
Hope they find/solve soon the problem.

Same problem here, all packages installed and after start the sim still freeze on checking for updates.
First app update on wu13 it comes sometimes but now it happen almost always, but if i unplug my network cable the game start, it work on the loading schirmish freeze too.

I joined the AAU2-Beta on my Xbox and it fixes the startup problem. I currently have all my add-ons installed again and the update check is working now. Thank you, everybody, for your work! I am looking forward to the full release of AAU2 and all the other things coming up on the roadmap. :slight_smile:

When is the release date?

According to the roadmap, AAU2 should be released in about a month, on June 23.

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes I have similar issue

Provide extra information to complete the original description of the issue:

I have them after SU13 ,all updates installed (worked with SU12 ) , I think it is correlated with the quantity of files . I did a full new installation , I think was above 450 files , when deleted one of the addon from the same airport from different providers , new addons for installation appeared , it was Reno Race and Top Gun. When downloaded them and go to play the sim , crash appeared . When restarted the sim no access to market place , all content was missing and permanent check of content was running.
Was If relevant, provide additional screenshots/video: