Stuck on installation manager after update!

I open the simulator and it is stuck on installation manager…checking for updates. It freezes there. Using Beta 1.34.15.

same here and i am not on beta

greetings JARVG

I’m not in the Beta and have the same issue.

Same issue, not in beta

Must be a outage

1 Like

Same here. I updated the USA pack, restarted the sim, and now I’m stuck. I’ve tried twice. In beta.

Yeah, same here

Apparently it’s an outage that, unfortunately, doesn’t get communicated by the forum nor the software.


I’m not in the Beta and have the same issue.

Same here tonight. Beta .15

Same here, stuck in check for updates
I am in Beta

Same here. Latest Beta.

Same here. Not in the Beta

3 other simmers acrosse UK and Netherlands too, beta and non-beta.

same here, outage… @moderators

Same here. Locked out of development for the mean time. No beta.

Spain is down as well

tried a workaround, disabled ethernet while it was stuck, clicked next and then enabled network… it’s progressing now, let’s see if it will startup for real…

Update, seems to work! please try!

1 Like

Yep. We’re back in business. It works for me now.

1 Like

Back online