Stuck on loading page/ unable to play

I’m about sick and tired of MSFS. Been a simmer since the 90s and was really enjoying this one until recently. STUCK IN LOADING SCREEN. I can’t even get to the HOME PAGE. When I first experienced this problem I did everything in the book and nothing worked. So I decided to completely reboot my computer and reinstalled everything and it worked fine for about a week. Now I am back to square one. Unable to play the game. Community folder is completely empty. I’m to the point that I would not recommend this game to anyone as yet.


Have you tried launching the sim as admin and closing down any background tasks?

I totally understand what you are going through mate, especially when you have been a simmer since the 90’s…that shows how passionate you are about the Flight Simulator.

Just hang in there…you are not alone feeling this way. We are all hoping (the guys who have this issue), that the next update would take care of it!

I too have been on Flight Simulators since the early 2000’s. Spent so much time on it, that I got an ultimatum from the wife :slight_smile: FS2020 really was great till is stopped working. Lets keep our hopes up for the next update in 06 days!!

1 Like

Last week I started MSFS and 28 minutes later I got the main menu. No idea why it took so long. It was on “take the pilot’s seat” 24 minutes or so. I checked the MSFS directory during the long wait and several cfg files got changed and performance monitor indicated 4-5Mbit at times… I did not count total download, but MSFS did do internet transfer. So I just let it run.

I have pretty much tried everything u can think of

Thanks man… it’s pretty aggravating

It’s an awesome simulator but has to many issues man

Sounds very much like something else you have running on your system is interfering with the game. What other programs and background tasks do you have running at boot up?

Yes it does have many issues still. But it’s the only option except Google Earth, to fly over the earth. I like to be able to set time and weather. In Google earth, i cannot do that. Nor can I fly a C172 in Google Earth. For me, the current simulator works fine. I don’t need AP or ATC. I’d like to see better photogrammetry, that is my main wish now.

That’s the point! When you’ve tasted fine dining since the begining, it’s difficult to eat peanuts!

FS2020 went way beyond it’s previous products, and you can see that with the guys who are having no issues after update 5.

They (ASOBO & Microsoft) just need to get it fixed for the blokes who have been affected since update 5, so that we all can have a blast…and reach for the sky…and move in the same direction :slightly_smiling_face:

Yes, very very tired…
This issue seems to come from the MS servers ; I can play but only without data.
I give up this game ‘til it works again. Maybe one day…

How much is in your Community folder?

Edit: Scratch that - just re-read the top post…

When you say “I decided to completely reboot my computer” did you mean reformat & reinstall windows?
Im only asking because reboot means restart, as in turn off & turn on again.

The fact that you had it working again, & then it stopped working again makes me wonder if:

A: You may have installed something after the sim was working again that is causing the problem.
B: Windows update has installed something you don’t know about that is causing the problem.

I had so many problems with the sim until I followed a guide which showed me how to Re-install windows without all the unnecessary Junk that comes with it, & then prevent windows update from installing things without my knowledge. It also showed me how to reinstall my graphics drivers without all the junk they also bundle in.
In short, a clean computer is a stable computer.
I reckon there is a big conflict or residual file there somewhere that is stopping the sim progressing.

This afternoon (Sep 1) I was able to load MSFS2000 & exited from it. BUT on attempted reloading (multiple times!) it CTD while loading. I’ve turned off Dropbox & Malwarebytes & my webbrowser, and removed several but not all of what’s in my Community folder. Also rebooted my computer along the way.

Very disappointed, but I’ve turned off that computer & will hope that MSFS works tomorrow…

yea since SU5 it crashes a lot. Random. cant reproduce.

had twice, and once when install game year ago, all 3 times alt+f4 and start again has been solved the problem

I’ve had the same issue. Started after the last update. The app freezes after plane and departure airport has been chosen and I click ready to fly. Task master shows MSFS tack is not responding.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.