Stuck on loading screen /

1 make sure windows system32 drivers etc hosts file (edit with notepad) has no lines at the bottom not starting with #. If so erase those lines.

2 try moving OFFICIAL\Steam\fs-base-nav folder to the desktop temporarily and try booting MSFS

3 try moving C:\Users\YOUR COMPUTER NAME\AppData\Roaming\Microsoft Flight Simulator\content.xml file to the desktop temporarily and try booting MSFS

4 There’s another file in the same folder as 3 which tells MSFS where the program is installed (the last line in that file). UserCfg.opt
Make sure it’s pointing to the right folder (edit the last line in notebook).

1 comes into play when using Google maps instead of Bing maps

#2 is what solves this issue for me

#3 is the order of arrangement that all your addons will be seen by MSFS. Sometimes it gets corrupted. MSFS will rebuild this file in the correct order, of currently installed addons when you boot up MSFS, if the file is not already present.

#4 I see messages about this file here from time to time.

I have the same problem. Stuck on loading the game with a full blue bar. Reinstall the game does not help. What is the golden solution.

Check my answer in my previous posts up, you might have corrupt files. That was my problem.

Hello. Do you have a stable game now or do you still have the same issues. I have the same problem (stuck on the blue bar) and don’t know how to solve it.

Near the top of this thread is a link to the checklist for this issue.
Have you completed that checklist?

I tried this several times now but no results. I think that it something is with the microsoft store or xbox app.

Try to copy your folder of Microsoft Flight Simulator folder to a different location/disk. If you get a message where you can’t copy a file, it means you have some corrupt files and you just have to delete those and re-validate through steam.

Hi there! I just bought a new drive to my pc…reinstall the MSFS from scratch on this new drive and the ■■■■■■■■ stuck screen continue…almost 30 days already trying to fix this non-sense…any help please!

Give us more info to work on.
Win 10/11 ok?

1 Like

W11. It get stucked on this screen

I can’t help but @MichaMMA might have some ideas.

… there are a lot of ideas within the forum and also within the official FAQs ( see above posts ) :slight_smile:

The common thing I have in mind is, that former was the Google-Map-Replacement installed and that @Rafapiloto195 forgot to clean its windows hosts file : so please check e.g. World map zoom in hangs/crashes the game - #13 by MichaMMA

Other common things are like login-issues, anti-virus-tool, somewhat within community-folder if not cleaned while re-install, old %AppData% files ( e.g. rolling-cache … see also ), etc… Would be nice if we get some info what was already tried.

I’ve reported to Asobo support as well and they’ve instructed me to join the insider and install the update 10 beta…now I can fly…


This is happening to me as well. This is a new PC build. MSFS has worked before. I did install a new video card and 2 SSD’s just before it stopped working. The old card was a GTX 1660 super. New card RTX 3070 Ti. There have never been any 3rd party apps installed on this computer. This build is only a couple of weeks old.

Things I’ve tried:
Repair MSFS, MS Store, XBOX app
Reinstall MSFS 3 times
All drivers up to date, and correct
Logged off store restarted and logged in store

Latest attempt: uninstalled MSFS, ran uninstalled cleaner, ran registry cleaner, reset both MS Store and XBOX app, ran updaters, shut off computer, waited 30sec, restarted, reinstalled MSFS, and still hung up.

MS Windows 11 home
ASUS ROG X570 Crosshair VIII Hero WiFi
-both cable network cards are connected
-one is high speed one is regular speed
-Wi-Fi card is also connected
AMD Ryzen 9 5900x
Corsair iCUE H150 RGB pro XT liquid cooler
Corsair Vengence RT 32GB x4 for a total of 128GB
Creative Soundblaster Z SE
Main drive: WD_Black 1 TB SN850 NVMe internal SSD
Other drive: crucial MX500 1TB SSD ( wiped old drive)
Other drive: crucial MX500 500GB SSD (wiped old drive)
Corsair RMX series RM1000x Gold power supply
EVGA NVidia RTX3070 TI FTW3 video card
Thrustmaster T Flight stick X
Logitech z625 speakers connected with optical cable
Corsair 5000x RBG case

This maybe too much info but I think every bit helps.

My next attempt will be the usercfg.opt and see where it says the program is installed. It was working fine with one SSD now I have 3.

Any other suggestions? Thanks

You’ve probably covered a lot of this, but here is a link to the checklist on the issue.
At the end of the list are links to four other checklists.

I have been through all of that. There was no config file. I’m currently doing a total computer reset.

After a total wipe and reset of the computer. It still freezes at the loading screen.

I have the same issue, never had this before.
To work around it, when it’s stuck at the loading screen and that the blue progress bar is full, I just disconnect the internet and it will almost instantly pass. Then reconnect the internet.

The issue is as usual the Microsoft servers.


2nd this! I have same issue. It is on Microsoft end I’m pretty sure as well. Removed all items in the community folder. Didn’t help. Safe mode got me in, but it’s in offline mode, sooo, yea… it’s the servers.

1 Like

I was gonna post having the same issue, but then I saw this message on the fourms:

But yes, disconnecting the internet and reconnecting actually solved the issue temporarily