Stuck on Syncing Data after downloading Fenix A320

Hello, the sim has been stuck on syncing data once I try to open the sim. This started happening after I downloaded the Fenix A320 last night. I’ve tried removing the Fenix from the community folder and no change. i also deleted a couple files to try and restore vanilla state and still no luck. Any advice?

problem with the server since 10 minutes

Really because I’ve been experiencing this issue since last night. Any time frame when it will be resolved? Still not resolved

Hi there,
I moved your thread to Install, Performance & Graphics. The Basic Gameplay Help section is for people asking flying questions.

So a friend of mine called me and said his sim was stuck on syncing data and no matter what he did it would not open the sim. I got on this forum and found where someone tried this and it worked:

Open Microsoft Store and log in
Go to the library and run Update
After all is updated, Log Out and Log back in
Then Reboot your PC

I had my friend do this and it corrected the problem. He started the sim and it opened up just fine!
Hope this helps.

1 Like