Stutter and Stop at 10FPS introduced with World Update 3 still there with 1.14.6.0

Same problem here, started with world update 3 (UK)

2 Likes

Definitely having the same issue. HUGE FPS hit in VR. Stutters, screen drags, its awful.

The last 6 flights I’ve attempted, the sim crashes to desktop before I can leave the ramp when I try to power through it, hoping that once I get in the air it’ll smoothen out.

I’m on a 10700k, 32gb ram, and a 3090 with Reverb G2.

1 Like

Hi Tom, as requested I did the approach a few times. Both with the A320, as well as with the Robin DR 400, which I normally fly. With both aircraft I could not perceive any stuttering or extreme fps drop.

BUT - I could not detect any more stuttering yesterday, even on my test route that I have flown over and over again in the past few days.

How it came to this yesterday, I don’t know - maybe a lower server load or some changes on the side of Microsoft …

But I will continue to monitor the situation.

Best regards
christian

1 Like

hi christian thanx a lot for taking you time to check this :slight_smile:

that’s really stunning. at this point (a few miles before EDDM 08L) i can reproduce the stutter/stop on my computer every time i try it and with lots of aircrafts - even those without a glass cockpit. and also when both caches are deactivated and online data completely switched off.

ok - so could it be that with you and your computer yesterday the problem as such had completely disappeared and therefore there were no problems with EDDM 08L?!

that’s what i always thought too, that it must be the online data or its delivery by the microsoft servers. only this is somehow contradicted by the fact that (at least on my computer) the stuttering/stop also comes without caches and online data???

that would be great! i’ll add a screenshot here later where exactly i always reliably get stuck so you can see if it’s exactly the same point we’re talking about.

thank you very much for your effort. let’s hope that the error will be found soon and the sim will run as well as it did before world update 3. until then i never had even the smallest problem and wherever i flew everything ran smoothly and without any problems. and i never had ctd or anything like that. since then i never changed anything in hardware or software or settings the whole thing is a real mystery to me.

kind regards
tom

I start to get the feeling that there are 2 major problems here with the performance (mind you I am in no way a technical expert). But there seem to be the horrible major drops in fps to single digits lika at Bishop Airport (76T) and then there is the occasional stuttering which seems to be somehow connectet to streaming /loading/processing the scenery.

I mean when I fly over open sea, there is no stutter what so ever. Of course there is alot of ocean but that is what I noticed.

1 Like

Someone found a short-term workaround that appears to have a large helpful impact on the FPS performance bug…see this thread and many have tried it with success.

1 Like

A workaround involving messing in the dev mode. For sure it is a stop gap. But you don’t put a band-aid on a profusely bleeding wound…

At least it gives the devs directions where to look for this s**ker.

2 Likes

Here also, terrible performance using a 2080 super and i7 10700k, 32GB ram @ 3600mhz. Im finding it anywhere in the world, every so often dropping to between 10-20fps, stuttering is awful, please fix ASOBO!!!

2 Likes

Add me to the list. I’ve had this issue all over the place since last update, to me it looks totally random. I get this massive drop from 40-50 fps to 10 fps, my GPU (3090) usage goes to down to 10% or so, and it will come back to normal after 30-40 seconds. Sometimes a bit longer. I’ve had this in the A320 (with or without A32NX), the TBM 930, and even in the T-45C Goshawk from Indiafoxtecho. It’s not linked to a plane or a place for me. The last time it happened while I was starting from a cold start at KCNY (near Salt Lake) with the T-45C. I tried the same spot this morning, and everything was fine.

I also get drops to 19-20 fps, same thing… completely random. Less drastic, but still a PIA.

It even happens in the menu, if I quit my flight while this is happening, menus are sluggish and unresponsive until it suddenly comes back to normal.

I still can’t understand how things like that can go though QA without getting flagged but I guess we will never understand…

3 Likes

I have now tried all the tips and ideas that have been posted here in the forum for weeks. nothing has really helped me.

in summary, there are 2 major bugs in the programming of fs 2020 that were not present before world update 3 (uk):

  1. since world update 3 there is the problem that in flight at certain ‘hotspots’ - which don’t have to be graphically demanding - after a short phase of increasing processor load both cpu and gpu fall to almost idle and the whole thing then stands still or drops to 10 fps. this usually recovers after 20-60 seconds to stand still again afterwards. the whole thing repeats several times in a loop until this ‘hotspot’ is over.

  2. since sim update 3 the behavior described above has worsened and sometimes even in the menu the framerate drops to 10 fps every now and then. additionally the performance in normal operation has permanently decreased by about 10-20%.

5 Likes

This did it for me. I was seeing FPS in the 20s after the March update under same conditions where I was previously seeing 50s. Recommend trying this if you haven’t might work for you. Thanks for posting!

“that’s what i always thought too, that it must be the online data or its delivery by the microsoft servers. only this is somehow contradicted by the fact that (at least on my computer) the stuttering/stop also comes without caches and online data”

You are never truly offline. Even when you have all settings in game set to “off”

Check flightsim.exe in resource monitor. There is still network activity. Presumably MS have some need to constantly run validation or whatever. So, even though you aren’t streaming data there is something going on here.

1 Like

So…i was in Kensai Intl Japan.No cache(i deleted it),also downgraded some options in graphics (not needed with 6800xt Nitro Plus S.E ) and guess what ?
Besides the rediculous SLIDE SHOW while approaching,i also saw another thing.

CARS AND TRUCKS DRIVING FROM THE AIRPORT TO THE MAINLAND…VIA SEA !!

No more than 9 bugs they say eh?

1 Like

does anyone know why asobo/microsoft this time did not update their ‘MARCH 18TH, 2021 DEVELOPMENT UPDATE’ to ‘APRIL 25TH, 2021 DEVELOPMENT UPDATE’ where they publish among other things the list of the worst bugs and the assigned priority?

You mean this?

1 Like

at least for me and the described problems 1.14.6.0 patch did not change anything. even the menu again slows down to 10 fps sometimes. do you guys see better performance?

Check there, seems it helped most people. I am not one of them unfortunately. 60fps but still a stutterfest.

1 Like

Confirmed - I wasn’t having it before, but now I am locked at 10fps in 1.14.6.0.

Awesome.

1 Like

nothing changed at all… exactly the same as before. KATL arrival and the whole pc is freezing, cant accomplish a single task anymore. Meaning it will crash to desktop with all kinds of errors from apps that had a hang, from startmenu crash over kernelbase, to ntdll up to access violations because somethign overflows…

Really disappointing guys. worldmap still stuck at 10 fps too

2 Likes

Hi, are you using a Steam or MS Store Version? I’ve got a MS Store version, firstly I opened the MS Store and installed the update via MS Store and then moved everything out of my community folder before starting the Sim. I then opened MSFS and installed the update, and cleared the rolling cache in the options and closed the sim. I restarted MSFS, and everything seems to be working well.

1 Like