Stutter every exact 30secs after landing

When landing (just before the threshold) or after landing (when taxiing from the runway) i get a very annoying short freeze/stutter every EXACT 30 seconds and it doesnt go away.
(sometimes its a shorter stutter every exact 5/10/20 seconds)

I already wrote in the Aerosoft CRJ forum as i tought its CRJ related as i only fly this plane, but it seems not. They have 21 peoples logged who reported this issue but they are not able to reproduce it.

One guy said he has the same issue when using the FBW A320, the WT CJ4, and the CRJ.

What i tried:
Disabled Multiplayer
Caching is always OFF
Live traffic is OFF
Closed every background program and service
reinstalled the CRJ
emptied the community folder
and dozens of things more…

Its not a performance/framerate issue, the framerate is the same (30FPS locked with vSync).
Its just s hort pause/stop every 30secs, sometimes every 10secs.
It never happens randomly, it always starts when landing…

Any help or info is appreciated, it drives me crazy!. :crazy_face:

Aerosoft CRJ Forum where the issue is also discussed (21 peoples with the same problem logged at Aerosoft) but Aerosoft can not reproduce it right now:

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.
No, besides the planes.

Are you using Developer Mode or made changes in it?
no

Brief description of the issue:
After landing when taxiing off the runway or sometimes already when passing the threshold of the landing runway a spike in frameTIME happens exactly every 30seconds. Its not performance related, the FPS stay unaffcted (locked 30FPS with Vsync ON). But the short spike in the frametime leads to a big and annoying stutter that occures every 30secs and does not go away anymore.

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:
Land on an airport with the Aerosoft CRJ (or the WT CJ4 or the FBW A320NX)

PC specs for those who want to assist (if not entered in your profile)
Intel i7-9700K
ASUS STRIX 2080Ti OC 11GB VRAM
32 GB RAM
Samsung evo 960 NVME M.2 SSD
Win 10 64 bit

Build Version # when you first started experiencing this issue:
The one before the WU4 (dont remember the number) but still present after WU4

Are you on the Steam or Microsoft Store version?
Steam

Did you submit this to Zendesk? If so, what is your ticket #?
Not yet

The second video seems to stutter about 6 times in 10 seconds though? Is that a separate issue?

you are right. Its from a different user, not from me. I removed it as it seems to be indeed not the same issue as i have.

I’ve seen in a faq that fsuipc can do that depending on settings

yeah, the autosave setting. But i dont have FSUIPC.
There is no program running that would make sense to cause such a frequetn perfectly timed stutter.
As said, i disabled any 3rd party programm and eliminated every possible task service.

Its just strange that it only happens when arriving at any airport. It never occurs when departing or in-flight. Only after or just on the landing, this is what makes it weird. I guess there is something going on in the Background of MSFS, maybe its ATC related or to the ground services or something.

But i even have ATC completely disabled and it still happened.

Hello
Try this to see.
You can also try to remove the A320 default libraries (Remove the ones you have downloaded and put them in the community folder)
That solved the problem for me + disable live traffic.

I don’t have a windows apps folder in my c drive? I searched in program files and looked everywhere. I don’t know what is wrong with my pc… That vid would be really helpful too.

1 Like

Thanks for the suggestion. I had that disabled a while ago and i did not see any differenece at all.
Honestly, i think this goes into the “snakeoil” category as nobody could ever proof that it gained a single FPS or fixed anything. Or atleast, every YTer who is showing this “trick” never could explain or proof WHY they are doing it.

I’ll give it another try tho and if it fixed the issue, ill report back. But chances are minimal from a logical POV. Cause there is something in the background that triggers this stutter at the landing. Its not that i have constant stutters all the time.

EDIT: i already had it enabled as described in the video, so this is not the fix unfortunately.
Thanks anyway. :slight_smile:

1 Like

From Aersoft’s forums;

The simulator freezes every 30 seconds and I have FSUIPC 7 installed

According to user reports, it’s FSUIPC’s Autosave feature that causes these issues. The only way to avoid this for now is to disable Autosave.

So maybe try that if you have FSUIPC, found it typical that this mentions an exact 30 seconds as well.

1 Like

Thanks mort, already answered you in the TL3-Thread. I dont use FSUIPC and im aware of this issue. :frowning: Thanks anyway!

Might be useful to other users with a 30 second stutter though :wink:

That is for sure right. :slight_smile: sorry for being so selfish :smile:

1 Like

Check VRAM consumption :thinking:

Thanks, yeh, im always monitoring, you can see VRAM usage in the vid above. its around 73% of 11GB VRAM

Could it be ATC related, as the controller will usually ask you to contact ground at the point that you leave the runway?

Could it be that the ATC code is taking more resources than it should in doing this?

That is exactly something that im thinking of. As i am Flying on VATSIM i have ATC completely disabled, but it probably will still run in the background as we dont have a setting to disable ATC, only the UI and the Audio of it. Also i installed a JS mod that limits the messages in the ATC Log to only 1. As there was a stutter-issue at release when the log was getting too long. However, even with that fix, i had the stutters again last flight as soon as i touched down.

I have one other idea what it could be, i will test that on the next flight.

a new hotfix has been published… :clap:

But thats a completely different issue tho.

Have you tried to set lower resolution of the textures to try to consume less vram?