Stutter/FPS drop when panning camera views (NOT FIXED)

Please tag your post with #pc and/or #xbox.
Are you on Steam or Microsoft Store version?
Are you using Developer Mode or made changes in it?
Brief description of the issue:
FPS drop when panning camera

Detail steps to reproduce the issue encountered:
Move the camera inside a cockpit
PC specs and/or peripheral set up of relevant:
Not relevant
Build Version # when you first started experiencing this issue:
SU5- SU6- SU7…

The stutter/fps drop when panning the camera view HAS NOT been fixed.
Offscreen terrain pre caching settings can reduce it a little bit if you set it to ultra but in many occasions it doesn’t change anything.
The old thread about this problem has bene closed and this has been marked as fixed but IT IS NOT.

For me it only works when set to ULTRA
Tho I have to agree that latest update has introduced some stutter again but not as bad as it used to be

1 Like

I agree, even ultra doesn’t solve it. It didn’t work perfectly in WU6, SU6 or SU7.
Especially the first time I pan around 360 degrees I get extreme stutters (maybe 3-4 updates in 3 seconds), but I always get some pretty big stutters while moving around after that as well.


Yes I agree that ultra helps… but it’s not enough to solve it. Also the other settings like low, medium, high seems too similars to each other.
This issue has came with SU5 to match the Xbox RAM; and now even with terrain pre caching set to ultra the 32GB RAM I have, seems not well exploited.

1 Like

Yes it happens the same to me, there a huge fps drop; it goes on just for some seconds but it’s pretty ugly and immersion braking. This is going on since SU5; almost 6 months now and it seems too much for me.


I get the stutters no matter what graphic settings or camera view. Constant stuttering. Incredibly annoying. Only noticed this ridiculous issue since SU7


Please guys upvote this; everyone is having this issue, even if you don’t notice it or it doesn’t bother you.
Thank you.


I also have this same graphics stutter problem but it is more noticeable since SU7. I see the cpu max out at 100% when I pan the interior or exterior camera views. The gpu is only at 50%. Is there a setting to balance cpu vs gpu load?
#PC Microsoft Store version, Not dev Mode, FPS drop when panning camera, Sound crackle at same time, Move/Pan the camera inside a cockpit or outside the cockpit.


I have the same problem!! it happens mainly after 1 or 2 hours into the flight and also the Audio Stutters badly with panning stuttering, really hope that they fix this annoying problem.

1 Like

This is exactly what happens to me couple of hours into any flight with any aircraft ( even the light pistons) i hope this problem goes with the next update!


I just voted. there is something seriously wrong whenever using the camera. external, drone panning etc. I just did a flight KSEA-KSAN and got to gate and when I turned off engines and just simply looked up within the cockpit camera and bam CTD! not to mention stutter city everywhere I go. its only when I use the camera I get stutters and CTDs…very frustrating


Update - Additional testing - I set graphics settings to low and turned off some of the settings. Still get the graphics Stutter with the CPU heavily loaded, when panning interior or exterior cameras. The GPU is less than 50% load during the stutter.

Prior to SU7 I was flying with graphics setting on high and only occasionally noticed graphic stuttering. It was usable.

My #PC system i7-7700HQ 4 core, 16 Gb Ram, GTX-1070 8 Gb dedicated Ram.


Guys vote here too please we should try fix it

1 Like

Here below I try to describe more in details…
All of sudden, everything was good in the morning, right after I install newest Nvidia driver or the latest windows update, I can’t remember which one first…
and then I cannot load into any airport normally, it took me 10 times longer duration to get into the cockpit, and the frame rate is chopping like 1 fps or 2 in external view, cannot operate anymore, can’t play anymore, normally it runs at least above 50 fps, 2K resolution ultra setting (RTX 3080) in VHHH paid airport

To be exact, when it is in the cockpit, when I move the camera freely, it appears okay with good fps, but when it is in external view, when the camera moves, it drops to 1 or 2 fps, the frame rate is DEAD when the camera is panning, but it is strange when it moves up and down, it seems okay

So far I have done below but still no luck…

(1) Updated latest windows (Win 10)
(2) Updated and complete re-install latest Nvidia Driver again and again (511.79 which was released yesterday)
(3) Downgrade to previous Nvidia Driver (5.11.xx), tried 2020 version, still no luck
(4) Deleted manual cache and rolling cache
(5) Verified MS2020 game files in STEAM apps, it says complete with no issue
(6) Run admin cmd sfc/scannow, no issue
(7) Tried above everything with no luck and frustrated, I COMPLETELLY uninstall the whole FS2020, delete the whole folder in C: drive, reinstall it…but the problem did’t go away!!!

Don’t know what to do now…

I have no any mods in the community folder
I am not using VR
I am not using additional peripherals, I use only mouse, keyboard and XBOX gamepad
I use Geforce Experience to set best setting FS2020
I am sure the graphics card does not have any problem, it runs smoothly on other games and application

not best you can do :wink:

1 Like

I tried uninstall the GeForce experience as well, no luck

no, un-installing is necessary… Gerforce Exp. is in generally not a bad tool , but Optimize ( or also auto-optimze ) is not best choice… Choose then Reset Optimization and disabled Auto-Optimzation and let the game decide…

Latest win10 update I installed was yesterday the kb5010472 (.net) & kb5010415 (cum.)… You have different ones ? It tried spanning in middle of VHHH and see no issues so far…

What is your PRE-Cache Setting ?

actually every airport would have the same problem, including discovery, training, challenge etc…
whenever the camera pans, it stuttered, like 0 fps

Same windows updates as you mentioned…

Don’t know what is pre-cache setting…I suppose you are referring to the “Data” page in-game, right?
I always let it default setting, no change of anything and suddenly has this serious fps issue.
380 hours flying now, very frustrated…

1 Like

there is a in-game setting called like “off-screen pre-cache” ( rel. new setting ).

The OP mentioned it too:

But I remember that we get report about in case ‘Higher Settings for this’ :slight_smile:
( note: I have it at Ultra Setting )

One example post:

Not sure whether its relevant in your case, but may be you can have a look into.

so here is my update.
I am 100% sure the “Photogrammetry” is ON before I get the zero fps issues
So today I tried turn it off, everything back to normal
So I don’t believe my eyes, so I turn it back on, the zero fps problem comes back!!!
The question is…why???
What is just happening?
I am sure I can turn it on without issue previously, because it is by default, why now?
What have I lost if I turn photogrammetry OFF?