Stutter/FPS drop when panning camera views (NOT FIXED)

Set terrain precaching to ultra. This will increase VRAM usage, so make sure you’re not going over when everything’s loaded or it will indeed become slow! If so, change your settings such as texture resolution to reduce VRAM usage. Note that it still only loads things on demand so it’ll seem slow for the first couple turns around, then will be faster.

Terrain Pre-Caching on Ultra exacerbates the issue in some situations.

You have added approximately nothing to this thread.

The issue is still occurring in Jan 2023, and I believe it has to do with how the game is programmed on the back end, and is not something that can be remedied by settings.

That said: If the developers do see a solution to this somewhere in there, it would be a welcome fix! <3


All I can say is that I can live with a tiny spike and two dropped frames when quickly panning up and down at large airports (when viewed from the cockpit). PersonaIly would much rather Asobo use their valuable time fixing the bigger issues still within the sim.

1 Like

Having it any lower causes huge stutters and visual annoyances (specifically while panning), so I guess you’re having a different problem. Good luck!

There are bigger issues? Extreme stuttering when panning camera is currently one of the worst and also most voted issue present in game, fixing this should be Asobo’s priority…

1 Like

that was the best I read today :rofl:

Recently upgraded to a 4090 and 5800X3D.

Despite the huge FPS amount I get (for example +80 fps in ultra 3440*144 at KLAX) I get these stupid stutters when I move the view in the cockpit. Very annoying considering how powerful is my machine. I don’t understand, it does that when I move the view top to down (from the overhead to the glare shield). Why can’t it stay consistent?

Hi All,
I have just had a new problem with stuttering in the Sim.

This may not relevant to many on here as it was a Windows problem, but it’s something folk should be made aware of as it takes only a second to check and it may help someone.

The Flight sim would stutter for a second or two then run normally for 8 seconds then stutter again didn’t matter what settings or connection speed, inside or outside the cabin.
I would have sworn it was the internet connection part of the Sim as it was never-ending, as I could play World of Warships on a different server with zero problems, so I wanted to check the graph in " Task manager " (ctrl/alt/delete) and the graph showed practically zero usage.

I then opened my " device manager " in Windows 11 and noticed it kept refreshing every few seconds. Inside the applet, all the devices would disappear and then re-populate, in other words refreshing constantly sometimes every 2 seconds or every 10 seconds this looked very similar to my Stuttering rate in the Sim but I thought if this caused the stuttering in the Sim why not in other games?

Anyway long story short I googled the problem and found many others who had the same problem with Windows.
I was so close to wiping the drive and starting over again, as I have found other problems with Windows 11 but life’s too short to go into detail.

If you have the “refreshing problem” in device manager, To Fix it, you disable the SSDP Discovery Service, and the problem goes away. Maybe not a solution more of a workaround until Microsoft waken up ( Thanks to CharlesHanson2 on the Answers. Microsoft website)

Path to SSDP Service
Right-click the Start button / click on Computer Management / Services and Applications / services / SSDP Discovery ( Bottom of the list click on standard ) then Double-click the SSDP discovery service to open its properties / Disable and save. The " Flickering Device Manager " stopped immediately.

1 Like

As soon as I start taxiing the issue goes away, it’s very frustrating as it breaks immersion during the flight preparation.

Also I don’t have this issue when I am parked at my arrival gate.

1 Like

I made a video showing the issue.

4090 / 5800X3D / NVME / 32 GB 3200 CL16

3440*1400 / Ultra / TAA / TLOD and OLOD 150 / No traffic / DX12 and FG / KLAX Inibuilds

You can see lateral panning is smooth, but panning up to down always gives my stutters.

I tried setting my render scale to 200% (6880-2880) to be less CPU limited but except increasing the GPU consumption it doesn’t do anything.

As I said the issue goes away when starting the taxi and it doesn’t come back when at the arrival gate.

What can I do? Isn’t the 5800X3D suppose to be good for MSFS? The issue goes away when I set my TLOD at 50 or less but what the point?


As a guess, the poor precaching behavior for airport objects is causing unloading of parts of the airport scenery when you look up at the top panel, then reloading as you zip back down to the forward view. Being close to the terminal and the problem going away during later taxi may lend credence to it being the terminal itself that it’s unloading/reloading.

Personally I can’t imagine that interfering much with ability to enjoy the sim, though.

Why this sim doesn’t even use the RAM? What is the point of having 32 GB when the sim barely uses more than 10 in complex situations?

IMO it breaks the immersion when preparing the aircraft before flight. I love the smoothness provided by FG, it is really a game changer. You can really feel the difference between 40 and 80 fps in complex airports.

It’s frustrating as Asobo doesn’t even give us an answer, they could at least tell us they won’t do anything about it, so we can stop to hope.

As you said it could be related to complex airports, as I don’t have this issue on all airports.

From the brief testing I did, I think it is working.
Whenever I flew around big airports in a drone, I used to encounter intermittent stutters of one to a few seconds every so often. After disabling SSDP Service, I haven’t seen the same long stutters.

Exactly the same problem occurred to me after one of the November Windows updates. It’s still the same to this day. My specs 5 5600X, RTX4080 (from two weeks, previously 6800XT).

so after a bunch of testing i was able to fix the stuttering by reverting back to NVidia driver 522.25. So far this is the only thing that seems to work for me.

1 Like

Funny enough that was my favourite driver, it’s certainly quicker than those that immediately followed. Others had problems it though so I guess it’s all pot luck… However habit tells me always to stay current so I’m on the latest as usual. If I don’t like it I can always roll back one or two

1 Like

Just a theory here, and I am only speaking about my system and my experiences, a lot of the stuttering seems to occur around the 45 deg points when panning inside the cockpit. It is both left and right panning but panning to the right seems somewhat worse.

It makes no difference how fast or slow, it will always stutter around these points. However the speed with which I pan definitely exaggerates the stuttering. Faster panning, more exaggerated stuttering. Once I get past that 45 deg area things smooth out until I come back the other way.

Up and down panning never seems to stutter on my system, only left to right.

The theory is, can this be related to whatever was done to give us the ability to set up multiple monitors? Put another way, did they separate the graphics in such a way that there are essentially 3 different ‘screens’ being displayed, left, center and right? The stutter points being where the sides of each area meet.

Just a theory. Whatever it is, it is annoying as heck and would (will) greatly enhance immersion and enjoyment if/when done.

Hmm, the multiple screens system isn’t tied to any specific number or particular angle of screens; I don’t think it’s related.

This is more likely related to the feature that removes items from memory if they’re behind you (frustum culling). Make sure terrain pre-caching is set on “Ultra”; however this doesn’t apply to all objects I think, which may explain the remaining stutters as objects get re-loaded when you pan enough to the side.

Right I don’t know if it is or isn’t as far as sectioning out viewable screens, just trying to understand why the problem seems to be tied to such a specific, repeatable location.

Pre-cache has always been set to ultra.