Stutter/out of focus/double image when turning

Hello all.

I am having a tough time figuring this out. I’m usually very good at resolving my own issues, but i have tried nearly everything i can find online and I’m still having the following issue. My pc specs below.
Intel Core i7-11700F
48GB RAM Memory
NVIDIA GeForce RTX 3060 Ti
500GB SSD. Win 11, latest drivers. Nvidia latest driver 497.09
Ques 2 with oculus usb cable.

When flying straight everything is great. I have smooth gameplay i can move my head around the cockpit and also outside of aircraft and the video is nice n smooth. As soon as i start to bank even doing slow gentle banks when i am looking left or right the ground seems to stutter, almost like it goes out of focus. If i pitch then the image in the front of the cockpit like the outside world also does the same thing. I have been trying for over a week to get this sorted out. Have tried minimum settings down to where the game looks like a hot mess and still doesnt help. Have tried many of the refresh rate options, scaling, have tried tons of different ways with the oculus tray tool. I mean i have literally been trying things for over a week and nothing seems to help. Im really at a loss here. I can still fly and have a good time but its just bugging me and i want to know how to get it fixed. Thanks.

I am going to go with a hunch that your memory is not helping you. It looks like you have an odd number of memory sticks installed, three sticks of 16 Gb? I believe that would automatically disable dual channel capability which be hampering memory performance. I would start with removing one stick of ram and making sure you have the two remaining ones installed in the correct memory slots to enable dual channel and also go into the BIOS to make use XMP is enabled so your memory is running at its correct speed. Incidentally make sure you have matched ram sticks I.e. speed and capacity, ideally two sticks of exactly the same ram.
Hope this helps.

Try to lower your in-game render scaling if you haven’t yet.

I have 2 16gb sticks and 2 8gb sticks of ram.

Have tried that. Down to super low and still has the jitter

Yes they are in the correct spots. Pc says it has 48gb of ram in the system information. Just wierd that if I bank and actually stop rotating like bank and let go of the stick it goes back to smooth. It’s only when I’m actually sending command to the aircraft whether it be roll or pitch.

with Quest 2, I always need to run the FOV to 0.7 0.7 or less using the ODT to get rid of the stuttering.

Given you have 2 sticks of 8Gb and 2 of 16Gb I would still be rather wary of how they are impacting performance even if they are rated at the same speed… Personally I would be inclined to remove the two sticks of 8Gb, ensure the 16Gb’s are definitely in the appropriate slots, and ensure XMP is enabled in the BIOS. This should cost you nothing but a little time to try out.

Set in game vsync to 30 fps and restart sim!

I did try removing and using just the 2 16gbs and the 8gbs in the correct slots and it didn’t help with the stutter. I will have to look into the XMP enabling in the BIOS.

what does vsync have to do with vr?

to OP, do not know how it is with the Oculus, but it is often due to the reprojection, as intermediate images are used. If the vehicle moves quickly, the repro can no longer keep up.

so i went into the BIOS and verified that XMP was turned on an in the task manager confirmed that i am running the 48gb of ram at 3200 mhz. Have also tried more settings from various topics in this forum and still nothing :frowning:

thats what im leaning towards. But i dont see an option to turn that off. I have searched. Maybe ive missed something but just cant seem to find how to turn that off in quest headset.

Ok just updated to the latest nvidia driver and still have that stutter. Really no one that has come across this or can help?

Not sure if you’ve tried them, but these two settings might help:

  1. in the game, under general options, graphics, VR - change ‘Off Screen Terrain Pre-Cache’ setting to Ultra. Then restart the sim and try a flight.

This setting seems to affect how the sim loads the view around you. Anything less than ultra may cause stuttering for some people. You can see a discussion about it in this VR thread - Off Screen Terrain Pre-Cache.

  1. If the above setting doesn’t fix the issue, leave the off-screen precache setting at Ultra, and try the following as well:

I see that you’re using a Quest 2 with usb cable. Do you know whether you have Asynchronous Spacewarp (ASW) enabled? You can check this via the Oculus Debug Tool. The tool is usually located in C: Drive, Programs Files, Oculus, Support, Oculus-diagnostics. You’ll see an application called OculusDebugTool. Open it, and a small window will appear. Approx. half-way down, you’ll see a setting called Asynchronous Spacewarp. By default, it’s set to Auto. For me, that causes stuttering in the game. Set it to disable, load the game and then try a flight.

Note: The ASW feature resets itself back to default (Auto) each time you finish your VR session and shutdown the PC. Therefore, I incorporate this simple change into my workflow each time I load the game.

Let us know how you get on.

Yes I have the off screen terrain…to ultra.
Yes have verified the asw is off.

Setting FOV values to 0.6, 0.6 really help the Quest 2 perform better.

I’m on Quest 2 as well, and I have the same experience. However, unless you can run the game in VR at 90+ FPS, then big/sudden movements will give you that effect. Imagine trying to watch a football match on a 30Hz TV.

The only thing that helps, to a certain extent, is to try to get as steady framerates as possible. If you are limited by mainthread, decrease terrain LOD. If you are limited by GPU, decrease resolution or graphics settings that are GPU intensive.

If you load up the performance overlay in the debug tool and begin flying what kind of average % overhead are you seeing? I run a i7 10700K and 3070 and try to keep my overhead between -70 and -120% overall. My max frame rate is capped at 30 and I mostly fly with ASW off. It’s not perfect, I do notice the horizon flicker when I bank hard and when I’m very close to the ground objects stutter slightly (e.g. a windsock or house splits slightly into 1 or 2 objects and I can’t focus on it). ASW 30Hz does fix it, but I find it a little too ‘smooth’ for my liking.

I am also having the same problem but with Reverb G2.
The problem appeared a few months ago, perhaps after SU5.

My system is
i7 9700K @ 5ghz
32GB RAM 3200mhz

Recently I can’t solve even with reprojection since it doesn’t even get to 30fps (without it’s around 45fps), I also tried with low settings but nothing changes