Stuttering in VR on Ryzen 5 5600X, 32GB(this time @3800 CL17) and RTX 2080 Super

Here I come again with stuttering!
So something even stranger happened today then the last time
I complained about stuttering(please assume that I have everything setup and adjusted properly before replying).

Some of you might have already seen my thread about stuttering in VR on Ryzen 5 5600X, 32GB(this time @3800 CL17) and RTX 2080 Super. So I was selling my old GTX 1080 and the guy asked me to film GPU and benchmark and while doing that I said to myself why don’t you try MSFS 2020 in VR with GTX 1080, so I did. Guess what? There was no stuttering at the same settings as they were for RTX 2080 Super!!! Yes the object were ghosting and shimmering like on 2080 but only when I flew at 100 feet and looking at them through side window but no micro stuttering, very now and then slight stutter but other than that smooth as a super-cooled helium while 95-99% utilized.

Immediately after that I put back my RTX 2080 super it’s back, it’s ■■■■■■■ back!! Stutter world while only 73-78% utilized! CPU in both cases was on all cores 4.775 GHz and utilized only 60-ish % and Default ASW mode @30Hz. 750W Corsair gold series but 6 years old. GTX 1080 sold because I made a deal before I run it in MSFS 2020 VR. Flight was 3rd leg of France bush trip and both runs. I flew the same leg, same settings, same flight path, same stunts and low flying on both runs.

Any ideas?

Different time I assume? Much of the stuttering I sometimes experience is server-related. I often switch servers to get rid of them. If I play on European server when it had a lot of players around me, I experience stutters, if I switch to South East Asian server, they are gone immediately. I play on ULTRA on 5800x/3080/32gb ram.

It’s pre cached, same leg and same conditions

Hi, I have a similar issues which did not happen with my old gtx980ti. When juddering and stuttering are happening, if I focus window to anything other than game screen would reduce them dramatically (but still shaky). Have you tried that?

You could also try my solution to the problem:

I’ve had this effect for months. In VR, alt tab to another app. Smoothness, but no mouse control. Alt tab back, mouse returns, but stutter does too.

I’ve always thought it was some kind of timing/interrupt conflict but I have not been able to really isolate it.

Do you have an ultrawide screen + normal screen? Please HAGS off and I think you can solve the problem. I just solved this last night…

Single 4K monitor plus G2 VR, and hags off.

Post SU5 things I’ve found to help with sidelook lagging…

  1. Force enable resizable bar. The msfs profile in NVidia disables it. You have to edit the profile with NVidia profile inspector. It’s not part of control panel, and your hardware and bios’s have to be updated also. This used to not help…now it helps.
  2. Use a 16 GB ramdisk for the rolling cache. I have it set to store to disk when I shut down and reload on startup. I have 64 gb at 4000, cl18.
  3. Disable WMR cliffhouse so it isn’t running in the background. WMR has to run, but cliff house can be disabled. …also gets rid of that dissolving triangles thing for faster switching.

Sometimes I get a stutter or two, but I can whip my head side to side and the image doesn’t distort or pause.

I disabled smt (multithreading) in bios…ran the game…reversed the process enabling smt…IMPORTANT you must cold boot and unplug your computer for a minimum of 30 seconds after holding down the power button for a forced restart. Then I enabled threaded optimization in the npc to on not global preset on. Looks better but still stutters at 100ft but not under 1000ft like it used to

Thank you for the information! I will try 1 and 2 as mine is VIVE!!!

How do you disable WMR cliffhouse, to get rid of the triangles?

c:\Windows\SystemApps\EnvironmentsApp_[bunch of letters]\EnvironmentsApp.exe

Move it, or rename it so it doesn’t run. I named mine EnvironmentsApp.exe.bak

The cliffhouse won’t load or take up memory. But VR will work fine, when you hit the VR key (whatever you have it asigned to), it’ll just jump right in.

Cliffhouse is useless anyway.

I am Admin, but cannot rename this. But thanks anyway.

You have to take ownership if admin accounts on your PC don’t have full access to this file.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.