Stuttering only when I start in 2D and then switch to VR

Hi there - 2d settings all set to ultra, VR settings a mix of ultra and high. Running a 3080, I7-10700k, Reverb G2.

I tend to get pretty solid VR performance when I load into a flight in VR from the getgo, but I am noticing that if I start a flight in 2D and then switch to VR, the VR performance is pretty bad. It stutters like crazy and is basically unusable. Any suggestions on a potential way to address this? Sometimes it is helpful and easier to start in 2D to get the aircraft ready and use NeoFly, etc., and then switch to VR for the flight.

Ummmm. I’ll try what you suggest. What happens if your 2d, start a flight switch to vr…stutters, right. And what happens if you stay in vr and lauch a new flight from world map? You mean go to vr before your first flight? Right now I’m experimenting with nvidia shader cache to on. It did seem smoother but at this point I’m probably wrong.

Using a Radeon 6800XT I start VR first, then switch to 2D to load the sim and only go back into VR when the flight is up and running and paused. No problems that way at all. I can then switch in and out of VR without CTDs or stuttering.

I’m thinking that Radeon owners are having a better run now than nVidia users, which is quite a turnaround.

I always start VR with my RTX3070 around 10 minuted before launching the Sim, and that’s for a specific reason: heating. I let the headset (Oculus Rift CV1) with a peace of rope to trigger the proximity sensor so the screens turn ON and the headset get warm. It will avoid steam inside it. After that I always follow the same process than you, start the sim with the headset on my desk, navigate menus, chose and start the fly. And then, before take off, I switch in VR. Never had any issue going back and forth from VR to monitor after that.

I heard starting vr both ways…I’ve heard quest 2 users are advised not to start vr until the assets are loaded and your in flight. I heard the reasoning is that the headset analyzes the output resolution of game right before it turns on. So in a sense, turn vr on while in flight. Honestly, I’m having a random issue where the game forces a reboot of my pc. Probably happened like 6 times already. A normal person would assume a faulty psu…but I’d take the Pepsi challenge against my hardware vs msfs reliability.

You are absolutely right, a faulty PSU doing that? No way!


I appreciate the efforts and links…mines an immediate reboot to post screen. My psu is rated at 750 and I’m using 650w. Right at 20 percent overhead. I seriously doubt it, but anything is possible at this point

I have kind of similar Problems and solved them. Try this:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.