Stymied by "Cannot Log You into Xbox Live" Message (PC User)

I have been away from the simulator since before Update 6, returning today to encounter the above message blocking my access to the game. Soon after I boot up, I get the message. After I click “OK”, the program tells me to “Push any Button to Start.” Once I do that, I get the “Cannot Log You into Xbox Live” message again, putting me into an inescapable loop. Anyone know what to do?

Current outage with MS, affecting allot of Services / Systems.

1 Like

I’m having the same issue. I booted up flight simulator, then I was taken to the screen showing where you would login for the first time, but the box where you would enter the credentials is black. Then, after a few seconds, it took me to the Push Any Button to Start screen.

I now have a different kind of problem. When I boot the game up, it tells me (as is typical) that there is a mandatory update (I assume #6) and that I need to go to the Microsoft Store to install it. However, when I look up the game at the store, while it shows that I own it, there is no update option. Instead, it just says “play” which gets me back to the game and the same screen saying that I need to go to the store for an update. Anyone else with this problem – or better, a solution?

Check for a thread about installing the Xbox app. Seems that’s necessary this go around.

Download and install xbox app

Restart PC

Launch xbox app and sign in.

Recheck for updates in microsoft store app

Thanks. Saw this solution on another thread – it worked.


Closing as I believe this was solved, please let me know if I misunderstood anything. If anyone has similar issues, please refer to the links above and the other thread which may help.