SU 6 - Thrustmaster TCA Battery bug, again? Not fixed?

Hello guys!

Can you please confirm?
The battery bug where buttons 3 and 4 were turning completely off the battery in some planes, is still here?

I saw yesterday in the SU6 Notes that now they put full compatibility for this hardware and I did the stupid thing to reset my settings as today the TCA Add On controllers arrived and I thought was good to use their default mapping.

Doing this, the bug turned back to me… :frowning:

Thanks in advance!

That’s weird, the TCA doesn’t have any battery switches bound to the buttons. I’ll have to revisit my bindings again to see if there’s anything to notice. I’ve been working to make my mods compatible with SU6 for the past days and I haven’t actually got the chance to fly yet.



Here is the original post with the temporary solution: Thrustmaster TCA Quadrant ENG 1+2 - Engine buttons turn off Master Power - Bugs & Issues / Hardware - Microsoft Flight Simulator Forums

Strange you’re not having any issues.


Looking at the original issue. Have you checked your assistance settings? And make sure you don’t have conflicting issue in all your connected hardware?

Buttons don’t click themselves. Even if they do, it’s usually switched into the correct position.

You might need to post some videos.

I record all my flights from beginning to end, so issues like these are easily identifiable. And I’m actually livestreaming right now, and I can’t seem to replicate your issue. I am using the FBW A32NX Dev version, though.

Hmmm, I need to check all these but since the bug came out in the past months, I’ve exluded the switches 3 + 4 on the TCA from the faulty bindings and everything worked fine.

No resetting to defaults, the problem seems to be still active and never solved.

Well, if it’s on another aircraft that’s not the FBW A32NX… I can’t help you. I uninstall every other aircraft in my sim, and I only kept the Asobo A320 for my Air Traffic, and the FBW A32NX for my flying exclusively. The Cessna 172 and the TBM are there because I can’t remove them. But I never fly them, and I don’t know how to operate GA aircraft.

So if the TCA quadrant have issues with GA aircrafts, I can’t help you. Since I never have the need to replicate them there.

But the general rule is, if the default mapping doesn’t work. Create a custom profile and make something work from there. The TCA quadrant default profile is designed for the A320 or Airbus systems. So if there’s issue with non-Airbus aircrafts. You have to figure it out yourself and try and experiment different configurations until you get it working. It’s also a good practice to create separate profiles for each aircrafts anyway.

Heck even I have a separate profile for the A32NX and the A330-900neo on my TCA Quadrant. That way, if I need to fly different aircrafts, I just switch the profile that I’ve reconfigured to work specifically for that aircraft.

1 Like

Thanks for dedicating your time here.
I have the TCA hardware for almost a year now and never had problems with any type of airplane at all. I’ve prepared a custom curve for the A32NX and another one for the GA.

Then, last June the bug came out with the 3 + 4 switches and till today it seems is not fixed yet. I am afraid the bug is not related to the A320 series but on some GA aircrafts, this is why it works for you.

I am not sure but I have in mind that you have to delete engine 1 and 2 in some GA. Got it at a Cessna 172. After a while plane shut down. So try to delete the buttons for engine 1 and 2 in a GA. Maybe it helps.

1 Like