SU4 constant CTDs

Updated to SU4, now I constantly get CTDs either when switching on VR using the shortcut, or when using [space] to recenter the view. Have been unable to play, although I have so far started the game for 20+ times. Have tried restarting my computer.

So far the only somewhat reliable way to switch on VR has been during the Checking for updates screen, otherwise it just crashes. But then it crashes later on, either when it asks me to press [space] to recenter, or when accessing the map in order to prepare a flight.

Before SU4 VR has been absolutely stable for me, with absolutely 0 CTDs since I began playing.

Hardware is a Vive Cosmos using the OpenXR driver, on an Nvidia 3090

In the release notes it says this. Related?

I did have the CTD on exiting VR, true. The crash I’m experiencing right now though is completely new, and happens when turning on VR, or on recentering (mostly on recentering, but not always).

After a lot of retries I managed to start and play the game. I’m staying away from using the recenter options, as this seems to be a crash trigger.

Otherwise not noticing any performance improvements, seems to work as decently as before.

What runtime are you on? If you’re on v106, switch to v105. Can’t hurt

I think the runtime is included with the Vive Cosmos OpenXR preview driver - 2.0.16.1 OpenXR Preview (Developer Beta), so I have no idea what runtime I’m on. I’ve installed this because in terms of performance using OpenXR directly is much better performance-wise than going through the Steam runtime. Unfortunately Vive Cosmos is ■■■■ in terms of support, so the driver has been a preview for months now (there is no OpenXR stable, and default stable is half a year old at this point I think). That said, this is the first time I’m genuinely having major issues with the game, and I do suspect the latest FS update to have messed things up.
So far in flight it runs stable, with no crashes. Will press space to recenter once I get in the ground and I’m done playing. Will see if it still crashes , or it prefers crashing on the menu.

EDIT: funny, cannot use c r a p :slight_smile:

Don’t have VR myself so can’t help you further, but hopefully someone in the community can help you out!

Thanks, I definitely appreciate you trying nonetheless.

I’ve seen 2-3 people in the update thread mentioning CTDs in VR, so I might not be the only one.

For what it’s worth, it didn’t crash at all during 3h of flying. I even recentered the screen a couple of times. Will see what happens next time I run the game.

I was crashing constantly when switching to vr after updating to SU4. Turns out the new nvidia driver I updated to at the same time was the cause of the ctds. There is a hot fix to 466.55 that fixed my issues. It fixes ctds if you run a 4k screen and switch to vr.

1 Like

OpenVR has the same issue. After a landing challenge it’s bringing me back to the main menu but before arriving there i have a CTD

3700x
3080
Latest Nvidia Drivers
OpenVR - Steam - Quest 2

Every update seems to break down the game even more than that it fixes something.

You are very welcome, it helped me too. I will mention your success in the Nvidia driver thread. BRGDS. Charles

If you lower your OXR setting (say from 90 to 70), do the crashes stop? I was tweaking graphics settings and noticed if I set OXR to 100, I would always get a CTD when switching to VR - OXR at 90 or lower, no CTD.

Not sure it’s possible to do with the HTC Vive OpenXR driver. In any case, I feel after the first launch it’s gotten better (there has been a HTC Vive driver update in the meantime). It can still crash in the menus, but it’s not as sensitive as before, and in-flight I have not had crashes so far.

Interestingly my setting are OXR65/TAA100 and I haven’t had a single CTD since the SU4. Not sure it it’s connected, but it’s very possible… I did have very rare CTDs before the update, but not usually.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.