SU5 Drone and Dev Camera gradually "comes out of alignment" while moving it around

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.
Yes, but removing them doesn’t fix the issue.
Are you using Developer Mode or made changes in it?
Yes, for the Developer camera, but the issue occurs in Drone cam outside of Dev Mode as well.
Brief description of the issue:
While moving the camera using the WASD keys in drone or dev mode, the camera gradually tilts in a counterclockwise direction. This occurs no matter which direction the camera is rotated, but some orientations make it tilt faster.
Provide Screenshot(s)/video(s) of the issue encountered:


Detail steps to reproduce the issue encountered:
Load into flight. Activate the drone camera OR activate the dev camera. Hit the spacebar to center the camera forward. Tilt the camera down a bit. Use the WASD keys to move the camera around. ← Do this for like 5 minutes, watching the horizon. Notice how the horizon tilts.
Build Version # when you first started experiencing this issue:
SU5 - 1.18.13.0
Are you on the Steam or Microsoft Store version?
Microsoft Store
Did you submit this to Zendesk? If so, what is your ticket #?
Nope

This issue also occurs in this person’s report here: SDK Virtually Unusable after SU5 - #13 by mkvy but I thought I would report it separate because that person seems to be reporting too many things at once.

I can confirm that. It was a bit like that before but after SU5, the effect is far more pronounced. Filbert also mentioned it during his last flight :wink:

2 Likes

Yup. Never seen that before, and it’s the only issue for me since updating do SU5.
Although, folks say it gets fixed just by resetting the controllers to the default…that I’m gonna try later today…

It is not. I reset all my input devices after the Sim Updat 5 breakage. However, you can press space in the drone cam view to reset it.

This is yet another SU5 issue. Use the drone view - return to cockpit - after a couple of minutes return to drone. In SU4 and before position was as left. In SU5 it’s without fail tilted to the right.

1 Like

Did anyone file this on Zendesk already?

So, not helping, indeed.
You know what I thought at first ? :grinning_face_with_smiling_eyes:
I thought that somehow a bug in coding caused the planet to be detached from the Drone. Because I got a feeling as if it’s due to the whole planet “excaping” around the Drone. And likely the cause of weather bugs.

Alas, it’s just an input issue due to the optimizations for trhe TTSNBN … (Thing That Shall Not Be Named).

+1 on this issue. I can set my drone position, level to the horizon, make no changes to flight direction or any camera movement, and the camera will start to slowly rotate to the left - the horizon dipping to the right. Super annoying as I like to setup a plan with AP on one screen and let it go while I work on the other.

1 Like

Same issue.

Same issue…

Thanks in advance for solving this to the devs!

Bert

Voted.

Hopefully this issue is addressed in the upcoming hotfix.

Even when not moving the drone, the horizon tilts.

This has been my only major issue with SU5 (apart from a couple of CTD’s).

One thing that I’ve noticed in my setup is that if you use the space bar to level the horizon (this positions the horizon mid-screen) then it’s fine. If you move the horizon towards the top of the screen, then the rate at which the horizon tilts is related to how far up the screen the horizon is.

1 Like

Same here, maybe we have all the same Joystick or something?
I have the Thrustmaster Airbus Version…

I have a TM Warthog and Logitech pedals.

1 Like

I reported this on 9. August to Zendesk… lets wait…

Same here…