SU7: world map locked

Microsoft Store version, world map locked (click with the left mouse button but it does not move). Ok zoom.

Anyone have this problem?

Yeah, you need to go into options/controls and under mouse presets, select the default preset. If you want to create a new preset, modify the default to your liking, adding bindings till you are back where you started. Dumb but it’s a bug…another bug.


Thanks friend, now it works. But I’ve never touched the mouse configuration. :thinking:

It looks like the new release changed many presets, which is obviously confusing and inconvenient. Why it changed this function while leaving most of the other settings as they were is a mystery. Thanks for the info on the fix. I would imagine ALL of us are experiencing this glitch.

Closing as solution was provided. There have also been several other topics covering this issue.

See this topic:

The known issues also reflect this with a workaround:

World Map:

  • Using a mouse with a custom profile will not allow you to pan across the world map. Revert your mouse to the default profile as a workaround, or rebuild a custom profile from the default mapping.