SU8 regression: Incorrect cursor position for right eye

Microsoft Store version, no Developer Mode

The cursor position is incorrect for the right eye. The regression was reported during BETA tests, but was not corrected before the official release. The bug is potentially dangerous for our health (eyes), as it results in us trying to focus on the cursor even though it is not possible to do so!

I am also having this issue. A fix is needed!

The mouse has been seriously messed up in SU8. If you select locked mode you cannot push or pull switches. I you choose legacy mode, it is a pain trying to map the cursor to the button.

I always dread updates… Asobo ALWAYS break something that was working perfectly well before… usually in VR!


Just did a random flight in the Aviat Husky having been part of the BETA program. I did have an update but wasn’t aware that it was the release version of SU8.

Just for balance, I had no impression of an issue with the mouse cursor. I did note that the cursor was perfect for clicking on the garmin map + and - buttons, which is often a problem for me and needs me to close one eye to get an accurate cursor position. Tbh though, i always thought that particular issue was usually aircraft specific.

I’m not getting this bug.
What VR headset are you using ?, it might be specific to certain ones.
I’m using a Quest 2.

Try an instrument view. That’s where it happens for me (G2).

1 Like

Thanks for your feedback. Could you maybe post here a screenshot of how your cursor looks over the gauges in VR? Please move your head close to the gauges first. Thank you!

I’m using HP Reverb G2 (v2). Is there anyone using the new Reverb G2 who doesn’t have this issue?

I don’t see how a screenshot would help as it would be of my monitor view not the headset.

I still have the double vision after the recent (03/03/2022) update.

PC Steam version
Reverb G1 2nd gen

EDIT Turning off Home Cockpit Mode worked for me

The reprojected image on your monitor of what your two eyes see shows the cursor position mismatch.

1 Like

Take a closer look at the screenshot in the first post. The cursor for the right eye points at a different location than the cursor for the left eye.

There has been a workaround found! :smiley:

I still see two dots and home cockpit is off.

The double cursor is back even with Home Cockpit turned off.
I have not made any changes to FS2020 and AFAIK there have not been any Windows updates since it was working correctly.
I am at a loss why it suddenly came back.
I have logged it in Zendesk