SU9 Autopilot Horizontal Control Broken

While using ANY GA aircraft since SU9 - G1000 (tried both Cessna and Diamond) and 6-pack, AP is unable to control the aircraft horizontally. When something like HDG or NAV is set, AP will “move” the controls to get the aircraft where it wants to go, and looking at the controls in the plane you can see this animating perfectly. However, the sim for whatever reason does not actually apply these effects to the aircraft, leaving it as if AP was off and I was not giving any horizontal input with my controller. In GA, the right-pull tendency then puts the aircraft into a spiral.

I also find it interesting that I have complete horizontal control over the aircraft with my controller - usually AP will fight me unless I make an extreme input that disables AP, but that does not happen now.

Vertical control by AP seems to still work fine.

Here’s a video of me in a G1000 Cessna 172, though as mentioned above I’ve been able to replicate this with the 6-pack 172 and the DA-40.

I have uninstalled the G1000 NXi package, and I have also removed ALL items from my community folder, yet this issue still persists.

This is the case with all aircraft that user MSFS Autopilot, from the C172 to the 747 and everything in between. Also noticed that while the control surfaces within the aircraft are trying to react to the AP, the ailerons outside the aircraft remain neutral.

Are you using Developer Mode or made changes in it?


PC specs and/or peripheral set up if relevant:

PC i7 1100k, Nvidia 2700 super, Logitech extreme 3d pro joystick/xbox controller (tested with both)

Build Version # when you first started experiencing this issue:

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

I have not encountered such behavior all throughout the SU9 beta testing with the C172S G1000. Perhaps try installing or delete/re-install the Working Title G1000 NXi

I do however have the issue where manual yoke inputs are applied oppositely if the AP is active (but we are not supposed to steer thru the AP anyway).

@nblew, use the Working Title G1000 NXi.

1 Like

I have been using the Working Totle G1000 NXi, and had just updated to the latest version v0.12.1 (though this was in issue while using their v0.12.0 before their patch), and the video reflects me using that.

I have since uninstalled the NXi package, and using the default G1000 also does not work. I did not expect this to work though as I mentioned in my OP that this issue happens even in a 6-pack (non-glass cockpit) aircraft. Reinstalling the G1000 NXi also did not work.

Why am I not able to reproduce this behavior in the C172? What if the game developers have the same problem reproducing it that I do? I recommend you add more detailed steps to reproduce it.

I would love to add more steps, and as a software developer myself I wish I could pin the problem down, but I’ve tried everything, and it just seems like the AP is broken for me in the base sim. I’ve tried multiple planes, uninstalling packages, clearing my community folder and the cache.

Maybe logs could help, but it’s not a CTD so I’m not sure how to generate and submit that. If you have any other troubleshooting steps or ways I can clarify/pinpoint the issue I’m open to trying things, as any mid-to-long distance flights in the sim are unusable for me

Do you have an adequate deadzone on your controller?
Do you have more than one controller plugged in?


In my case, some addons from the marketplace are not even installed to the community folder, but rather the official folder. Do you have any other addons besides the NXi from the marketplace?

Did you try with just one controller connected at a time? Maybe there is some conflict.

Does the problem only occur on mid to long flights, or can you easily reproduce it on a quick flight starting from any airport without a destination or flight-plan?

I tried turning dials and pressing buttons in the same order you did in your video, but everything goes well on my end. I don’t know what we are doing differently, if anything.

Thanks for the help everyone!

The issue had to do with the controller dead-zone. My controller has always had a bad deadzone and is getting worse apparently. Just recalibrated my joystick and AP is working fine.


I am having the same issue. I don’t think it’s a controller thing. I think for some reason, NAV won’t kick in unless you activate HDG for at least one second. This seems to be a bug. It’s not supposed to work that way.

On the plus side, take off, turn HDG on, count to 1, turn it off, and then it seems to work as expected

Topic Author selected solution.