SU9 Drop in FPS after 50 min of flight in TBM

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

YES

Brief description of the issue:

Hello,
I just finished my game by stopping the game during the flight.
Everything was fine, FPS at 40, gameplay smooth. I took off from an airfield in the Paris area, and headed to Normandy, I was at 30000 feet and suddenly my FPS went down to 5, I couldn’t get out of it, in outdoor view the FPS went back up to 38 but with big jerks. I don’t know if it’s a coincidence, but it happened when I wrote in the FMC, a destination airport and the STAR in the middle of the flight.

Provide Screenshot(s)/video(s) of the issue encountered:


Detailed steps to reproduce the issue encountered:

PC specs and/or peripheral set up if relevant:

W11
Processor: Intel(R) Core™ i9-9900K CPU @ 3.60GHz (8 CPUs), ~3.6GHz
Memory: 32768MB RAM
Available OS Memory: 32706MB RAM
Card name: NVIDIA GeForce RTX 2080

Build Version # when you first started experiencing this issue:

1.25.7.0


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Did you try the sim without mods? might take a couple of days for mods to update if anyone was affected by the new SU9

1 Like

I would try another flight, later, maybe it’s from FSPUIC, I would try another flight without, to see.

I had similar with this update when it increased the load on some cores of my CPU. It ran OK after I left it running.

I just tested, with my empty community folder, I was able to land without any FPS problem at EGLL, but on the other hand I was not able to write a flight plan in the FMC en route, because having also removed Navigraph, I had no more data.

Hi all!
I just wanted t oshare a tweak to the sim I was suggested from very unexpected source - Fenix A320 support, that fixed my FPS.
So from the beginning I was struggling with FPS getting to 5 within an hour from the start of the game, this morning I even managed to get 1 when I had aircraft in C&D parked at teh gate.
Anyways, I browsed lots of forums and tried turning V-sync and limiting FPS to 30 (no difference for me), I removed all world updates I had installed (apparently photogrammetry is causing lots of FPS loss - no change for me, I removed whatever I thought was causing problems from community folder - no difference).
Few hours ago I got a response from Fenix (I was in touch with them, because I initially thought that it was their update that caused by frames to drop) and they suggested turning OFF SCREEN TERRAIN PRE-CACHING to ULTRA (I had it on medium) - problem solved!!
I just finished flight with Fenix A320 London Heathrow to Ljubljana with no problems what-so-ever!
Give it a go, who knows, maybe it will work for you too!

Clear skies and soft landings!

Andrew