(SU9) Toolbar 'on' renders random switches inoperable

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?


Brief description of the issue:

I recently downloaded the new (and fantastic) JF BAe146 and, in VR, was having difficulties operating some of the switches with the VR mouse. They would light up blue, but would not operate. This included buttons, toggle switches and twist switches. I assumed that it was a JF bug.

However, after much experimentation, I realised that if the Toolbar is open in VR, then a number of buttons and switches become inoperable in the above manner. As soon as I switched the Toolbar off, even if the dialogue boxes/maps/etc were still on, the switches became immediately operable again.

With the previous bad experiences with VR Mouse and open dialogue boxes in earlier updates, I then began to wonder if it was actually a more general Asobo issue. And it is.

I opened another aircraft (the Cessna Skymaster) and exactly the same happened. With the Toolbar open, a number of random switches ceased to function. With Toolbar off, they functioned again. I know that those same switches were not affected by the status of the Toolbar before SU9.

I haven’t tried yet with stock aircraft but fully expect the same will happen where there are a large number of buttons and controls - the affected ones on the BAe146 and Skymaster are different buttons and appear to be random.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

Different aircraft chosen - same result.

PC specs and/or peripheral set up if relevant:

Doubt this is relevant. I number of other flyers with different specs have reported similar issues and have generally assumed that it is a Just Flight bug. It isn’t - it is an SU9 bug

Build Version # when you first started experiencing this issue:

SU9 Definitely not happening for the Skymaster in SU8

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

I just found this bug thread and realize the issue I’m having may be the same. I was asking a question in a thread, now I realize it may be a bug.

I have full control of all TBM 930 “dashboard” buttons (AP, NAV, etc.) when non-VR and VR without the toolbar. I push TAB to bring up the toolbar in VR so I can access its functions and many mouse-controlled dashboard buttons are dead. The buttons might illuminate but won’t switch on/off.

Here’s my earlier post: Is the TBM Broken for Anyone Else?