Suddenly after windows reboot FS shows LOADING in apps and features - NEVER loads

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?


Brief description of the issue:

fs seems to be stuck in LOADING even though I havent started it …it shows LOADING in apps and features

Provide Screenshot(s)/video(s) of the issue encountered:

Screen Shot 2022-06-07 at 18.10.23

Detailed steps to reproduce the issue encountered:

just start up windows and its there… I cant run FS2020 at all now…cant see any process running to Kill it in task manager

PC specs and/or peripheral set up if relevant:

Build Version # when you first started experiencing this issue:

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Anybody got any ideas how to kill this process…I havent even tried to load FS2020 , its as if it autostarts in this stuck mode when windows boots…only started today after a Microsoft gaming update
The screenshot is from teh "apps and features " page… it eventually stops saying “loading” so when it does stop I try to go to the advanced options page to reset or repair , and it goes into the loading loop again… !
thanks !

Check that your anti-virus isn’t stopping it.

Thanks but Nothing has changed in the worked fine for months till today … it looks very much like a Microsoft server/data connection/gaming app issue…
In total frustration (not the first time with FS2020 ) Ive gone for a reinstall of the sim …firstly I pulled my main FS drive which halted the "loading " process and allowed a reinstall… (which SHOULD be fast as I have FS on an external drive on which I can keep all the downloaded content …)
Im now TRYING an uninstall/reinstall… it sat for a long time on “preparing”. so Ive now uninstalled xbox app…and reinstalled that clean just to be sure … its now an HOUR into installing that xbox app alone,…,.its like the data connection to Microsoft has turned into a snail !
everything else running fine , and my connection is 600 meg up and down. !
This is a VERY frustrating setup/install process… ive spent SO much time troubleshooting it in the past …
Contrast that with X plane which not only installs fast but can be moved at will as its in its own unconnected directory…chalk and cheese…

this picture is after 1 HOUR of installing what is a tiny app !

Anti-virus updates definitions sometimes daily. What worked yesterday may not work today if it updated definitions. It’s happened to me when it suddenly blocked access to Discord.

Yes …fair play…I have malwarebytes (just turned it off…no change) and then it switches automatically to windows defender ( switched that off to try with no change either ) worth a shot, but not the answer…
it reeks of something Microsoft/gaming app/xbox. …as I mentioned…gaming services updated itself today why is it so intrinsically linked into all these other apps… and NO clue is offered as to why there is any issue… ? its now downloaded another 4 MB in the last 15 mins… !!! all other downloads are flying down as usual - its only microsoft it seems…

it decided to move on to a “something has gone wrong”. while trying to reinstall fs2020 error 0x00000001
I give up…im restoring windows from an image file …lifes too short to deal with this nonsense …easily the most fragile, and erratic install process of any program ive eve used…
UPDATE…restored to 2 days before, and of course windows store updated gaming services immediately, (which im convinced is what is breaking it ) and BANG…back to same stuck “loading loop”.
So now Im stuck…cant uninstall / reinstall, cant restore an earlier version.
wasted SO much time on this…

In the end I abandoned MS store version and re bought it in Steam… too much time wasted on tracking down issues…
installed without a hitch … …go figure. !