Support for Wide FOV VR headsets (removing Frustum Culling issue)-

Even if @mbucchia and J.L. created a fantastic workaround, I just want to bring the thread back to mind so that the actual topic doesn’t accidentally fall by the wayside.

3 Likes

The workaround is great for right seat flying but it is still so bad on the left the performance gains aren’t worth it, in my experience. I hope that the left can be addressed. Sad that this must be done in post given how it seems to be an issue easily corrected beforehand. Thanks to all those working for free to improve the product.

1 Like

woahhh - is it real? Who is in the Beta?

Sim Update 10 Beta Release Notes [1.27.9.0] - Sim Update 10 BETA / Beta News and Updates - Microsoft Flight Simulator Forums

2 Likes

Let’s see if this brings happyness to our problems.
In dx12 there must be some troubles with vr. They are investigating.
Has anyone tried the beta? :smiley:

I have installed it and… great!!!
THE FOV ISSUE IS FIXED AND THERE IS DLSS.
I have flied about 2 minutes and it’s amazing. Now the fov with pimax has no more strange things on the sides.
The DLSS works and has a good performance but even in quality mode it is still a blurred.
At the moment it is the best performance AA.

3 Likes

is this fixed in non VR mode?

He right! It’s non PP mode and I’m soaring in Large FOV.

Thank you for pushing this in the forums! I think it’s really here! Thank you to the developers! Sincerely you just unlocked my Pimax HMD for what I bought it for! No more blinders!

1 Like

It’s working great indeed! No need to keep hacking in OpenXR Toolkit!

3 Likes

Performance with DLSS gives you more fps but even in quality mode it is still a little bit blurred. Do you think they could improve the quality mode?

Hi,
I want to report something for your openxr toolkit. If Pimax XR is active in the control center, the horizontal offset in fixed foveated rendering is not working. And it appears C_/_.
If I change to SteamVR in the control center, it works but they move towards the same direction (both right or both left).
I hope it helps. Thanks.
Any posibility to add any sharpening when using dlss? In msfs it appears amdsharpening but it doesn’t do anything.

Hey, if you are using SU10, check out my other thread:

For short, Foveated rendering is broken when running SU10, and that explaisn what you are seeing.

You can already use sharpening, just turn on NIS or FSR and leave up-scaling to 100%. That will enabled “sharpening-only” mode.

1 Like

You are totally right. I’m sorry I didn’t read it.
Ok. I am using now Openxr toolkit sharpening at 100% with DLSS in game and now IT IS REALLY FABOLUOUS. It is not blurred like before. What a change!!!
Pimax 8kx, 3080ti
Many thanks.

Cool! Using NIS or FSR sharpening?

I have tried FSR. I’m going to try now with NIS and I will post it.

EDIT: With NIS it is much worse at 100%. There are jagged images. If I lower it then it is blurred.
At the moment FSR does the perfect job. It is quite strange that NVIDIA does it worse with its own gpus.

NIS at 100% is way too much sharpening, if that’s what you tried. NIS 20-40% is typically better.

1 Like

It doesn’t work for me.
When I activate WFOV Hack the image in my VR headset splits. It’s as if my eyes are not looking in the same direction.

Which version of OpenXR Toolkit are you using?

Also, given that SU10 will address the issue at the source, beware that WFOV Hack will be removed in the next version.

I was using version 1.1.3
I installed 1.1.4 and it solved the problem. :slightly_smiling_face:

Thanks

Yup! I accidentally broke it in 1.1.3!