T.Flight Hotas 4 not showing image

Brief description of the issue: In the controller settings, the “image” of the HOTAS appears as a question mark.

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered: Plug in a T.Flight Hotas 4 w/ drivers and stuff, the start up MSFS, then go to controller settings.

Build Version # when you first started experiencing this issue: Every versiom
Are you on the Steam or Microsoft Store version? Steam

you can still assign the controls, i have that to with a different controller, no real issue.

I know, but it is very annoying for me (as a newbie) to have to memorise the control mappings and for me to not be able to use Ctrl + C.

Maybe too late to help you as this post is a year old but I had the same problem.
I found out my T.Flight Hotas 4 was showing up with a slightly different USP product ID

Product ID configured for MS flight simulator for the T.flight HOTAS 4 in the settings is 0xB67B however mine was 0xB67C

editing the file
“C:\Program Files (x86)\Steam\steamapps\common\MicrosoftFlightSimulator\Packages\fs-base-ui\DeviceConfig\DeviceConfig.xml”

and coping the line

<Device ProductId=0xB67B TextureFolder=T.Flight Hotas 4 />

and pasting the copy and editing the product ID (below) to match mine fixed the picture issue.
||<Device ProductId=0xB67C TextureFolder=T.Flight Hotas 4 />|

1 Like

ugg the last line got messed up and I cannot seem to edit, but the line should look exactly like the line you cut just with the ProductId edited. Those || lines should not be in there.