Taxi ribbon not showing in Mission

I wrote a mission and found out that the taxi ribbons are not showing when using the mission. I do have this enabled in the aid section and they are showing after landing without loading a mission. Does anyone know how to enable in mission (xml code) pathway ribbons? I think within missions you can turn a lot of things on and off. It looks like it’s turned off by default but I’m sure there must be a way to turn it on within missions.

Thank you.

You can either select a preset in the .FLT:


Or edit specific items with an action in the .xml:

<ChangeAssistanceItemAction id="Turn on taxi ribbon" InstanceId="{}">

(Look in propmission.xml and propassistancepresets.xml for an overview of the possible values for the properties.)

In addition, you need to make sure the taxi route is actually defined in the .FLT.

Ps: Its probably better to ask these questions on devsupport, because I think more developers are on there to answer questions, as well as Asobo.

Thanks for the info. I will check that