TBM AP Bug VS selection bug (sticky key behavior on mouse select)

Came back to the game after a 3 week break and yeah, this bug is very much an issue.

It doesn’t just happen with VS it happens with everything.

Altitude knob will just keep going, sometimes quickly clicking the opposite way will stop it. VS generally goes all the way negative as far as possible.

Sometimes clicking twice will fix it. Sometimes it won’t.

I also noticed the speed selection was 900knots and climbing. Needless to say it looks like my 3 week break will be getting longer through lockdown 2. :disappointed:

still not fixed with last patch although they claimed to have fixed those AP control issues…

Thank-you everyone for posting and confirming this is an issue. As with some others, I have created a bug report and detailed as much as possible about this problem including multiple videos. My experiences is that this bug happens on longer flights and cannot determine any correlation to a ‘trigger’. I’ve experienced this on TBM, King Air and CJ4, though I haven’t flown any other aircraflt lately. Others have posted a workaround, for me I’ve mapped joystick buttons to move the VS up/down.

Please up-vote this issue if you can.

Still an issue confirmed. I hit VS in the TBM 930, attempt to change it, and when I do it just goes crazy in the direction I attempt to move the wheel in. It DOES work but it’ll go -4000 or +4000 to whatever altitude I have set regardless of what I put it to. I have also noticed this on other knobs as well.

This is not aircraft-specific by any means. It affects all the rotary and wheel controls on the 787, for instance. So it’s a generalized UI problem in the sim that began with Patch 5 and continues through Patch 6.

I also suffer from the same bug, particularly annoying in a fast plane because the sticky dial click on a VS descent for example will send you very quickly in an overspeed or G Force excess that will end the flight.
As reported by others, it’s not plane specific and it seems to affect all dials. I’ve had it many times now in the CJ4, I basically cannot do a normal climb / descend without having either the ALT, FLC or VS dials going crazy in one direction or the other.
I have upvoted here and filed a bug report.

1 Like

It’s also annoying that the vertical speed reverts to the last selected vertical speed when selecting the VS button. Instead it should maintain the vertical speed at the time the VS button is pressed, just like in real life.

1 Like

I am also experiencing this… causes a lot of violent jerking… i’m getting a lot of complaints from my passengers. :wink:

On the topic of autopilots and flight directors, this one also needs fixing finally! Please vote!

I’ve had this issue a long time now. Mostly I fly the TBM 930. In AP, click on the Altimeter knob to adjust the height setting and intermittently it could start spinning round and round on its own. The same happens with the VS Thumb wheel. Just spins round on its own.
I really wish this problem was fixed. It’s caused no end of crashes for me.

Altimeter knob? Do you mean baro setting or altitude preselect? And I assume you mean altitude instead of height?

I haven’t had any problems with it so far, I’ll give it another try.

Altitude preselect. And the VR Thumb wheel. Advancing or retarding either using either the mouse wheel or mouse left button can sometimes cause either to start spinning on their own.

The only really annoying problem I have with the vertical speed on any aircraft is that it reverts to the last commanded vertical speed when activated and not the current vertical speed as it should do. If last time you used vertical speed was 1000 ft / min climb and you select VS during the descent its gonna command a 1000 ft/min climb…

1 Like

It’s worse when you used VS on decent before switching AP off. I had it set to -1000 before switching AP off, then took off after landing, engaged AP while climbing at +!000 and AP almost tore the plane apart next to violently diving back to the ground.

Also is it normal for AP to put a plane into a stall when fuel runs out. (I tend to forget to switch tanks in time now and then) Alt hold desperately tries to maintain altitude into a stall. Switching tanks can easily be too late (plane flips down) and then AP is screwed up for a good couple minutes after you recover the plane.

When you turn it on again it immediately goes back to 100% up and a full right or left roll. It doesn’t only remember the last VS setting, it also continues from the last uncapped pitch and bank angles it was aiming for. Is there a way to reset AP without fighting it for a couple minutes until it behaves again?

Autopilot should disengage at stall warning! That is another significant bug. I think the problem is as follows (I can be wrong as there is many bugs in MSFS):

  • When insufficient power is available the autopilot pitches-up in an attempt to maintain whatever vertical mode is active, e.g. vertical speed / pitch / altitude. Only FLCH mode is relatively safe as the autopilot will keep maintaining speed and lowers the nose, nothing wrong here, works the same in real life.
  • The autopilot does not disengage at stall warning as it should. As a result, the autopilot gives full nose-up input as the stall occurs and also TRIMS fully nose-up.
  • Due to limitations set by the hardware you are using at home you are able to recover without changing or noticing the out of trim condition too much. Engaging the autopilot and letting go of the controls will induce a secondary stall as it takes time for the autopilot to overcome the full nose-up trim and retrim the aircraft.

In real life it would be very hard to push the nose down with a full nose-up trim. But most hardware can’t simulate those stick forces. Your joystick will simulate an out of trim condition differently from real life by having a fixed in-trim-point, in other words the center of the joystick (where it is spring loaded to) is the in-trim position. When out of trim you need to keep pushing or pulling on the stick. When trimming the aircraft you can release the stick back to its spring-loaded center position.

On the real aircraft however the in-trim position is not always the middle of the control column range, you can see it as the center of your joystick itself being moveable and moving back and / or forward depending on trim position. When fully trimmed nose-up in the real aircraft the problem is immediately obvious as the control column itself will be all the way back into your stomach.

Try to recover, re-trim and then re-engage the autopilot, maybe it helps. Or maybe its something completely different, but this is the first thing I could think about.

That’s what I do. I re trim the aircraft (hold trim down for a long time, it’s slow to move) then get level at 0% trim, engage AP again and it immediately trims back up to 100%.

The way out of it is to have enough speed (to survive the temporary 100% trim up) while pushing VS mode as low as possible until AP responds and finally starts to trim back down. It’s a roller coaster ride getting AP back on track. Sometimes it won’t recover and I’ve had to restart the game to use AP again.

AP seems to hold on to whatever it’s internal ‘solution’ was to get back to the desired height. Which can be 1000% trim up. The longer it was trying to do the impossible, the longer it will take AP to ‘get out of it’ after leveling / re-trimming the plane again and re-engaging AP.

(Btw, why does the Bonanza not have a low fuel warning. Every car does…)

Weird, I don’t think I’ve seen that one so far. I haven’t stalled the aircraft much on autopilot so maybe I should give it a try :sweat_smile:

Does anyone know if the original issue has been solved yet? I haven’t played since I last posted and tbh I don’t really wanna set up all my flight stuff just to find out it hasn’t.

No it’s still the same.

However using the scroll wheel is an easy work around (after assigning cockpit zoom to something else or button + wheel)

1 Like

Having issues with the buttons that increase and decrease the vertical speed. Regularly stick and end up crashing usually as my plane plummets to the ground. Pretty much happens on all planes. Any help please or is this a known bug.