TBM930: Can no longer move throttle between feather and power columns

In the TBM930, when starting the engine you move it from low idle, to high idle on the feather side of the throttle axes, and then once done you move it to the left. This can now only be done if you tell the checklist to do it. Simply clicking and dragging the throttle to the left no longer moves it over there.

Similarly when landing. I want to cut my throttle to zero but cannot because game will not let me click and drag throttle to the right column. Using legacy mode.

This happening to anyone else?

1 Like

Since you can’t turn the engine off, it means you can never “complete” a flight in the TBM930. Unless I am very much missing something here.

Hold Left click on throttle and right click simultaneously


Just hit CRTL SHIFT E and you turn the engine off.

Does this work in legacy mode? Or only in forced-upon-you-Xbox-mode?

I will try this on my next flight, thanks!

Only tried it in Legacy mode. There is another thread somewhere in here where you might get more info. Sorry.

There are so many threads regarding this that the mods can’t even keep up with merging them. But that also means that a quick search will get you all the information you need with little effort.


Once you get to high idle:
Place mouse over power lever
Hold left-click button
Tap right-click button

1 Like

Sticky a post then. Thanks for the info, honestly, it is much appreciated.

That one will only be fixed by a sim update I think - VATSIM / IVAO / PILOTEDGE Users - Be aware of an important bug! - #160 by Bishop398

This fixed it for me :slight_smile:

1 Like

Sadly all that happens for me is the camera zooms in, in VR, then zooms back out. The power lever slides to the left but then slides back to the right as the camera pans back out…not sure if this is a VR issue.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.