TCA Airbus Sidestick prevents my PC from entering sleep mode

Hello,
When my joystick is plugged in (via USB), my computer doesn’t go into Sleep mode. I have to unplug if I want my PC to go to sleep!
Do you know how I can fix this and allow my pc to go into sleep mode without having to unplug the sidestick every time?

One suggestion is to go to your Device Manager, select that device, right click on it and choose Properties. On the Properties dialog, select the Power Management tab and uncheck ‘Allow this device to wake the computer’. I use a USB hub, and have had to do the same thing to all ports on the hub as well. Hope that helps.

1 Like

If you have GeForce Experience installed that’s the culprit, try uninstalling it. Solved it in my case. Then you can try the Nividia App Beta instead of GeForce experience, no problems with that here.

1 Like

Thank you for your answer. I will try this

Thank you foe your help. Yes I have Geforce Experience installed.