TCA Quadrant Airbus Edition problem in dual

I don’t have any addons in the community folder.
I am not using developer mode.

I have an issue with TCA Quadrant Airbus Edition in dual configuartion. I have connected two of them, one set to Engine 1 and 2, and second for Engine 3 and 4. The first one (i.e. first two engines) is working properly, while the second one is not visible in the sim (I can see TCA Q-ENG 3 and 4 but no picutre and configuration options). The game itself is the newest version ( and retail one. I am not sure if I should report to it Zendesk or Thrustmaster support. I am trying to setup for Boeing 747i

using bing translate, it appears you have the filter set to “assigned” and not set to “all”. Change it to all and then you should be able to assign it.

1 Like

It works now, even though the picture is still not displayed. I assumed that the second throttle will setup itself automatically, like the first one.

I have another problem with the controller. When I swithc the on/off button, the engine is not switch from off to run (the fuel valve below the thrust levers)

Since the second device is not recognised properly, sensitivity settings are not good as well and I can’t find a way to make them work properly.

They are detected. They just don’t have a default profile. Sensitivity should be the same. Just take a screenshot of the first quadrant. And apply the same sensitivity curve as the second.

You might also need to do hardware recalibration process in the engine 3&4 mode.

Thanks. I managed to recalibrate the second one. The only problem left is with the fuel switch. Even though it is set in the key settings it is not working properly.

Did you follow the exact same setup as the first quadrant? I believe the default has 3 commands being bound into the same switch, so you might need to follow the exact pattern and concept into the second quadrant.

Somewhat unrelated…did your Quadrant include a USB cable?? Just got mine today and no cable. The device has a port on the back but did they really not include a cable?

Even the first one is not working (only the valve is open, not the run button below).

Yes, there was a cable, stickers with engine numbers and plastic elements to hold two of thrusters together.

I guess I just got lucky…thanks.

Actually, the little white cable – which is all of 4 inches long – is a USB B cable. The port on my TCA Quadrant device is a USB C port.

Have you made sure the first one is cleared of your custom profile and start from the default profile?

Yes it is cleared from the deafult profile.