"The airport should be in the same zone as the airport declared previously"

I am making an airport that is missing in the base game in Jinzhou, China and when I add an airport object the error “The airport should be in the same zone as the airport declared previously” shows up when I know that I am using the right airport icao code ( ZYJZ ) and placing it at the right coordinates for the airport (40.93, 121.28)

Any fix? :expressionless::expressionless::expressionless:

I had the same problem when making a fictional airport, in my case I was using an already used icao code. Once I changed it, all was well.

Have you set the right region?

Not much help I know, but I’m still learning!

This also happened on my own ZPPP airport scenery building. If I adjust the airport reference point near the stock zppp(wujiaba), the error disappears. but I will lose the surface of half airport area. Looking for a method to fix.

Similar problem here,… virtual airstrip in a place I like.
At first , I was under the impression that it looks for REAL ICAO codes ( the prompt says " ICAO check…).
Solved putting “Any string” as Display Name and “Same String” under ICAO code" like “XXXX”
The region country … must make sense with the geographic location you are locating it.(I guess)


1 Like

Same for me. I create the CTP4 Lac Pau Seabase before SU7. All works fine but now I have this error.

My seabase is very close than the CCP6 Caniapiscau stock airport. Is it can be the error origin…?

EDIT. I delete the CTP4 airport with the error and make a new one on the same place. Same error. Then I moved CTP4 airport some miles away from CCP6 and the error desapeared. I move again the CTP4 near CCP6, no error return and I could save the scenery.

Same problem here, I just discovered when I was creating my Brand New Scenery (also in real life), so my suggestion is, when you create a new scenery, before you start, check first if the ICAO code is already used by MSFS by default. If so, then the solucion is to create your scenery with same ICAO code plus a 5th digit…For example in my case it was “SCPD”, since this one was already used by MSFS I was forced to use “SCPD1” instead. Hope it helps until MSFS find a way to remove old unsed ICAOS. Best Regards