The Initialization of VR Failed

I´m testing things in VR, trying to see what my system can handle (Intel I7-700K CPU, AMD RX 480 (!) GPU, 48gb Ram, and a Samsung Odyssey+ Headset). Most of the time I can Fly, and get really blown away with the VR experience. Every now and then I get an Error Message when starting VR: “The initialization of VR failed. Please check that OpenXR is installed on your computer and your headset can use it.” It is, as I can walk around Microsofts VR mixed reality house on the cliff environment. So openXR must be working? The Error message only comes up sometimes, and I haven´t been able to track down the cause of it. Only way to fix it is a restart of the PC. Unplugging my Headset and plugging it back in doesn´help, nor restarting the Sim or restarting Mixed Reality. Anyone else had this problem?

I have the same and i can’t understand what to do when i get this message.

After some manipulations, close, ope, reboot and i don’t know others… it start again working, but its a painfull process which can last hours before working again…

i work with oculus Link, Quest 2, beta activated, runtime set to oculus one in regedit, etc…

I have the same problem, also i saw that i did the update for VR again on 10th January, before that it all worked fine. I did a complete PC reinstall (including Windows) but it still failed.

These connectivity issues could be related to incompatible USB drivers for Windows Mixed Reality headsets.

You can try uninstalling your USB drivers and installing Microsoft drivers and that Windows is using the latest build for 20H2. Clearly if your wifi is dependant on USB then make sure you have a way of rolling back if this fails.

More information in here.

I did a complete desinstall of Windows Mixed Reality and reinstalled it. Still get the message every now and then. Might be less now, but not sure. Something is unstable, but not sure what. I´m leaving it. Will fix itself as the Simulator goes along. You just have to restart things, and eventually it works. VR flying rewards you for enduring the little pains more than enough… :smiley:

you mean, sometimes it works and sometimes it doesnt?

I get this regularly, but only when changing the WMR render scale and reentering VR. Restarting FS always fixes it though. But yeah, really annoying!

I have similar issue, but in 95% cases it reproduces for me with steps as follow:

  1. Start MFSF,
  2. Enable VR and play for few hours even,
  3. Disable VR by key press (usually not intended),
  4. Then WMR portal starts and i’m unable to enable VR again.

I’ve never seen such problem in any other game or app (e.g. DCS, Star Wars Squadron, etc.), only in MSFS.
Also WMR portal works correctly. Looks purly like MSFS issue.
Any ideas how to avoid this? It’s very flustrating, as only restart of MFSF helps.
Restarting/shutting down WMR or OpenXR doesn’t help unfortunately.

I have this problem, I’m using OpenXR and G2, I can only enter VR once, returning to 2D and attempting switch to VR results in this error message. Coupled with the inability to load another flight plan whilst in VR it means that a sim restart is required before every flight. Very annoying!

Edit: So I have made a link with another problem I’m experiencing. Randomly when starting with the same settings and location I’ve seen a significant increase in FPS (44%). I tracked this down to the game/post resolution changing from 3172 x 3092 to 2538 x 2476 (OXR 100 TAA 80 instead of 100/100). I don’t see a change in EFIS resolution and all settings are fixed, no auto.

It appears that when the sim starts with this reduced resolution I can then freely exit out of VR and back in without any issue. However when it starts with the correct resolution I’m unable to relaunch VR and get the initialization error message everytime. Have tried different versions of OpenXR but doesn’t change this randomness.

Not sure what to try next.

Unfortunatelly, it still reproduces with update. Doesn’t looks for me to be depending on used OXR (custom render scale) or in game resolution.

Getting same message when switched to the latest AMD drivers (2020-21.2.3).

This is a new issue for me since last updated. Incredibly frustrating.

G2 Reverb received last weekend, got it up and running and now this weekend despite monkeying around with numerous OXR and WMR settings, and reboots, this happens every time. Any solutions? As an aside is it possible to close OXR and WMR while flight sim is open and then re-open OXR and WMR and get headset to work, or do both (or only WMR) need to be open (and minimized) before opening MSFS?

Still reproduces for me. Unfortunately the only solution that works for me is restart of MSFS. Restarts or shuting down OXR or WMR unfortunately does not help for me.

1 Like

I have Powerspec G358 from micro center with i7-10700, ASRock Z490 Phantom Gaming 4 Motherboard, AMD Radeon™ RX5700XT Gaming, 32GB DDR4-3200. I had downloaded the AMD Radeon software a while ago and remember making some tweaks to the software settings and that may have been why I got the failed initialization. I went into software this am and found an update was available, so downloaded it, BUT ALSO reset the software back to factory settings. Voila! Now no probs with the VR initialization on first attempt. Might this apply to anyone?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.