The store doesn't download the fix

The simulator advise me that there is the fix update, the store doesn’t download it…Why?

same thing for me in win11, no update available. not even the one from yesterday

it took like 10 trys but it finally worked, fix for freezes / CTD/s installed and what does the sim do?? freezes and CTD’s LOL… wow

1 Like

can’t even get passed the loading screen now.

some hotfix

Same here, I started the sim, he asked to install the fix, I did. But I still couldn’t make one flight. It always crashes before I can get into the cockpit. The first time it crashed while selecting control options, the second time it crashed with the aircraft on the apron when I wanted to hit the ready button and the last time it just crashed trying to load the flight… Getting really frustrated with SU5. It all worked so well until that SU.

well you aren’t part of the crowd where all hasn’t worked well since day 1. This is just icing on the cake as i’ve maybe completed 2 (very short hops) in a full year of having this stupid sim. i want my money back