Third party add ons not showing up

Every aircraft from the MP will work in principle. Some will be better done than others, in terms of flight modeling, depth of system modeling, etc. you can see this most often in the pricing. North of $ 60 is more ‘study level’ than a $ 14 fun plane.

I mean will they work when third party add ons will not.

Thats a generic structure.
Let me try to explain.
Your zip file, when you open it in windows explorer, contains a folder, with the name of the add on. That is what I called ‘some add on folder’
You need to out that folder in your community folder. That’s all there is to it.
You can do this by first putting the zip in your comm folder and extract from there.
You can open two explorers, with the Windows+E key combination and open the zip in one and the community folder in the other. Then you can just drag the folder from within your zip to the community folder.

Yes. Otherwise they wouldn’t be in the in sim market place :smirk:
But many add ons from flightsim work as well, as long as you know how to unzip a zipfile!

John get a headset for 10 or 20 bucks (with USB) and I will do the rest for you.

GhostlyFrend.
That is exactly what I have been doing over and over again.
I know it’s simple. I also know it does not work for me.
I download the zip.
I unzip it.
I put the unzipped file in the community folder. [ yes, the right folder]
It works…for everybody else, but not for me.
This is why I have now given up.

There is something wrong here, but I am not a blooming computer expert.
I have given up now. It’s not the end of the world.

I have a head set and use it on my PS4.
So how do I use it here?

i am 77 years old so forgive me for being a bit thick by the way.

1 Like

Does the content manager show the plane installed?

the 2 most common errors installing community content are

  1. using the Wrong Community folder, every install has at least 2, some have more of them - only One will work
  2. unzipping & moving the Wrong folder, the addons Must be placed in a specific folder structure

for the first i suggest finding the Community folder from within the Game, it will Always give you the correct one
for the second you will Need your folder settings in Windows set to Allow seeing the “Known File Extensions” so you can positively locate the manifest.json (manifest (dot) json) & layout.json control files used by the game

here is a vid i made showing how to do most of this (i dont think i show how to set the windows folder option)

You need to put the folder and not a file in the community folder

I downloaded the mod you linked above. When I download it, it looks like this in my download folder:

Then I right click, and choose “Extract all…”
Screenshot 2022-06-23 132502

Then click extract:
Screenshot 2022-06-23 132543

Once it has extracted, it opens the new extracted folder be default, which looks like this:

Now I right click on the folder shown here and click “copy”

Then I open up my community folder, and right click in it and choose “paste”

Then if I open that newly pasted folder, it looks like this:

2 json files and a SimObjects folder

Now, when you start the sim, you should see the plane able to be selected

The key is to make sure your community folder has the folder called jakger86-baron-g58-faarg in it and inside that folder are the 2 json files and the SimObjects folder

2 Likes


773
774

You say that you put the file in the community folder. I said put tge folder in the community folder. Don’t know if you did the right thing. Just trying to help, no offense and no impatience on my part :grinning:

Well, just listen to @gordongreig above he always explains these things much better than I can :sweat_smile:

2 Likes

Thanks to a very helpful member here [Scott] who took over my PC and spent some time on it it’s now working O.K.
Something stupid I did a few months ago sent some files to another drive and I think that was the problem.
I am not an expert on PCs so can’t get all technical about this.

Again many thanks Scott and what a helpful forum this is! :blush:

2 Likes

Could you mark one of the above reactions (the most valuable in your view) as solution? That will help others find this answer more easily. Tx!

Something that happened to me once: an addon didn’t show up in the sim. After some investigation, the unzipped folder had renamed itself slightly in the process, meaning it didn’t load on launch. A quick rename back to what it should’ve been, and all was well.

The folder that contains an addon can be any name as far as I know. For example, some addons can cause issues if they are loaded before others, so one trick was to put a “z” in front of their name, so they were read last.

I’ve never actually confirmed whether that actually works though, but some addon creators clearly do. :wink:

It could cause problems if you were using an addon linker though, though I have not tested that out.

I’m sorry ghostlyFrend but Scott fixed it not me.
When it comes to PCs I have the knowledge of a cave man.

What I mean is just pick any valuable answer, maybe the one in which Scott offers his service to you and click the mark as solution button. That way this thread gets tagged as solved and that’s helpful for people who are looking for answers in the future.
But no big deal!

GhostlyFrend,
ScottMDA contacted me and shared my P.C.
I sat chatting with him as he did lots of things, moved lots of files and stuff and did magical things to my P.C. A few hours latter we put a freeware add on in the community folder and it worked!
Hope that helps…not!
I am an old crinkly that struggles to even use a smart phone. :persevere:

1 Like