This SIM is unflyable lately for me

Like the title says the SIM has been unusable for me lately. I’ve got a solid internet connection of between 200 to 300 down with a ping between 30 and 40.

I’ve got a decent system - 13900 and 4090. I can’t play in VR or my monitor as the sim gets so jerky that it is literally unflyable.

I’ve tried the latest G force driver and also rolled back to 531.29. Which I have always had luck with.

Nothing helps.

Is anyone else experiencing this lately?

Try disabling or clearing rolling cache.

1 Like

And most important if you’ve changed your drivers… The Windows Shader Cache!!

How to delete DirectX Shader Cache in Windows 11/10

2 Likes

I can only second clearing the rolling cache. The last I knew I got very poor performance with it on. It works fine on off. No issues. 10700k + 3080 + VR

1 Like

You guys are all awesome. The problem is seemingly cured as I tried it out during the discovery flight over Rome in VR.

I’m installing the latest g force driver now to see if I have better luck with it now that I know what some of the ailments were.

Hello @Hoboflier,

Your topic has been moved to a subcategory of General Discussion & Community Support Tech Talk. The General Discussion category is meant for discussions that fall outside our other sub-categories.

Please check out these other categories for your future posts:

  • Aircraft
    is where you discuss current or future planes coming to MSFS as well as assistance with liveries.
  • World
    is where you discuss scenery, airports, and weather.
  • Aviate, Navigate, Communicate
    is where you ask for help with flying.
  • Tech Talk
    is where you discuss installation, graphics, drivers, performance, CTDs, peripherals, and hardware.
  • Menus & Activities
    is where you discuss activities (landing challenges, bush trips, etc), plus anything accessed by the menus including the Marketplace, settings, logbook, cameras, etc.

Delete rollig cahce
Also delete these folders:

%localappdata%\D3DSCache
%localappdata%\NVIDIA\DXCache
%localappdata%\NVIDIA\GLCache
%appdata%\NVIDIA\ComputeCache

How to

1 Start your PC in safe mode

  • Click start
    1start
  • Click power icon
    image
  • Press and hold left SHIFT key and click restart
    image
  • Select Troubleshoot > advanced options > startup settings > restart
  • Select 4 - Enable safe mode

2 Click start and type

%localappdata%\D3DSCache

Press Enter
Delete all folders

3 Click start and type

%localappdata%\Nvidia\dxcache

Press enter
Delete all files

4 Type

%localappdata%\Nvidia\GLCache

Press enter
Delete all folders

5 type

%appdata%\NVIDIA\ComputeCache

Press enter
Delete all folders

6 type

%localappdata%\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache\SceneryIndexes

Delete all files

Restart PC.

2 Likes