Throttletek Throttle always goes from 0 to 50% power

It goes to 50% power immediately I have tried everything any ideas ???

Hi @Brutus1951, and welcome to the forums!

Please check your Control bindings for the throttle. It must be set to “THROTTLE AXIS” Here are representative settings:

thanks i used the axis nothing works

Sensitivity settings? Calibration etc?

1 Like

Tried it !! Went with every setting nothing as of yet

And definitely have your hardware throttle assigned as “throttle axis” and not just “throttle”?

Have you tried removing all other controllers leaving only the throttle plugged in, restart the sim and see what happens?

After you assign the correct throttle axis, go to sensitivity move the throttle through its range. Watch the graphical representation to see how it behaves. You can also use this screen to add some sensitivity adjustments I’ve played with -30 and -50 with good results on my throttle.

1 Like

Hello, i have the same problem with my throttle axis with my Saitek flight throttle quadrant.
Did Asobo or somebody have any solutions?

Thanks, i will try!

I also have the throttletek but mine is going to 100% at 50% and then back to 0% moving it all forward.
Weird
Michael Moe