Thrustmaster hotas x no throttle

This would have been my first recourse since it seems to have helped some people.

Are there still setting files for the Aerolite stored in AppData\Roaming\Microsoft Flight Simulator\Packages folder? You could try deleting those. Is the throttle non functional when bound both to the generic throttle axis and throttle 1 axis?

Hi Pantszer:

Thank you for responding… An update as to where I am. Still experiencing the problem and the game is unusable. I uninstalled the whole program and reinstalled completely. I did this after trying to repair and them trying to reset the program. Neither worked. fresh install isn’t solving the issue either.
Sometimes when I get into the game I can actually take off before the throttle stops responding but then I’m stuck at full throttle with no way to reduce it.
I started to think possibly a hardware issue with my hotas so I borrowed the same unit from a friend who hasn’t even used it yet so it’s brand new. Same exact problem.
I’m at a wits end trying to get to fly.
There is no folder for MSF under appdata\roaming\microsoftFlightSimulator as I have not reinstalled the aerolite

I have what sounds like a very similar problem. Same throttle but it seems to think that the ‘closed’ position is at the midpoint of the movement. Seemed to work yesterday when I installed fs2020 but today totally screwy. I’ve also noticed that the options config screen seems unhappy because sometimes the drop downs work and sometimes not. Unfortunately I’m a complete newb so can’t offer any suggestions, but hoping to find some !

If you have the Steam version, you could go reset all your settings to default, delete all custom controller profiles, quit the sim and go delete the folder “C:\Program Files (x86)\Steam\userdata\Steam_userID#\1250410”, then reboot the sim and try again.

Note that this might delete your flight log information, if you care for such things. Might want to backup the folder in any case.

Edit: On MS Store version, it seems the analogous files are held in different appdata directory: Joystick Profile Location - Steam? - #5 by hobanagerik

Failing that don’t just delete that folder, but in addition: uninstall the sim; delete any cache files related to the game; go manually delete whatever remains of the MSFS installation folder and go manually delete whatever remains of the MSFS appdata folder. Then reinstall and try again.

Failing that, as workaround you could use programming software to assign your throttle to a virtual controller axis, then bind that virtual controller axis to the MSFS throttle axis. The game would think this is coming from entirely new, different device which might bypass whatever hiccup you are experiencing. I believe your HOTAS does not support the OEM’s programming software (TARGET) so you’d need to use third party one. Let me know if you are interested in trying this and I can make a small guide with pictures on how to do it.

Do you use throttle 1 axis 0-100%? It’s a full range throttle that has the forward thrust on one side, idle at middle and reverse thrust on the other side (only valid on aircraft that can use reverse thrust, e.g. Pilatus PC-6 or Cessna 208).

I’m not using the Steam edition, it’s from the MS store.

I may have given slightly misleading information about my throttle, it’s a Thrustmaster Warthog which is different to the OP’s kit now that I think about it.

I am binding the device axis to THROTTLE AXIS (not THROTTLE 1). Another strange bit of behaviour is the sensitivity graph which is now showing maximum output when the throttle is in the fully back position. Not at all consistent with the actual behaviour of the aircraft where zero output coincides with the centre location.

A further glitch is with my Saitek Cessna Rudder Pedals. The yaw axis works ok but the toe brakes have no effect even though they are bound to BRAKES.

A couple of questions if I may:

  1. where do I find the controller profile files?
  2. What’s the procedure for uninstalling the sim in order to start again ?


To clarify, my previous post was almost wholly in reply to OP. Only the last part after the quote was in reply to you, you can ignore the part before that.

The issue and hardware you are having are completely different to OP and you are kinda hijacking the thread here, so I’ll be brief. You have a HOTAS style throttle intended to for a twin engine jet with an afterburner detent. You’ll probably want to bind one throttle axis to throttle 1 axis (not the 0-100%) and the other to the throttle 2 axis. If the throttle is “going the wrong way” then you need to check (or uncheck) the “reverse axis” tickbox in the control options, right next to the appropriate axis. As earlier there’s an afterburner detent blocking the full range of the throttle, you might want to physically disengage it as there is no such detent in typical aircraft in the game. Consult Thrustmaster’s documentation on how to do that. Lastly, make sure your pedal toe brakes are assigned to right brake axis and left brake axis. Reverse axes if appropriate.

One way to configure reverse with just the axis is to put your physical throttle at its idle detent, then adjust the sensitivity screens Neutral slider for that axis so that the dot sits on the centre line. You should end up with a broke line. You can move the dot out of the way to ensure the break in the line is as close to the centre line as possible.

Thank you again… this is driving me crazy but what I didn’t do last time was delete the setting in appdata\local\microsoft…
So I am uninstalling and trying to find any remnants of the game to delete then I will reinstall. Let you know how that works out.
If purchasing a new (different) hotas would solve the problem for sure I’d go that way but there is no guarantee that it would work. I have a lot of money (to me) tied up so that I can fly and I don’t do any other gaming…
Anyhow thanks for helping and hopefully this time it will work

so to answer a couple of questions… I don’t have the steam version. I got it from the Ms store. I have the throttle bound in the default configuration which is just throttle not throttle 1. This has been working excellent for a couple of years. I got the game really close to the release date… Was very much looking forward to it as I had used FSX for years prior to this.

Again thank you. Yy new installation is at the mandatory update on first boot which takes quite awhile. I’ll let you know

Well finally the installation is done and I gave it a try… Unfortuneatly it is still not working for me. I must not have gotten the uninstall completely though. I must have missed something somewhere because it remembered the aircraft I last used and the airports I last used… I think I need instructions on removing the program completely. If I get those instructions I will give it another go… stilll hoping this will solve the issue… thanks so much for your assistance.

On a side note and not sure is this has anything to do with the problem but when the program is starting up and I’m going through the world update screens there use to be music playing or I think I remember music playing and it no longer does that so I’m thinking somehow it’s remembering a past installation because it was also doing that before I uninstalled

It’s probably recovering some settings from the cloud which means it could be recovering whatever is causing the error in the first place. The reason I recommended defaulting all (and I mean all, even seemingly unrelated) settings and deleting all custom profiles before exiting and uninstalling the sim was in hopes this would stop such recovery. Might still not work.

This is not exactly what I referred to and I don’t think anyone should need to buy new controller to work around what might be an issue in the game, rather:

First of all ensure your controller is working correctly otherwise. At very least, check the Windows USB game controller interface (it’s clumsily tucked away these days, run search for USB game controllers or joy.cpl). Possibly also try it in some different game to see if it works, if you don’t have one aside MSFS there are games which are free to use in the basic version around like DCS, Rise of Flight or Warthunder.

Download and install vJoy:

I personally use this version with Windows 11: Release v2.1.9.1 · jshafer817/vJoy · GitHub

This version might work better on Windows 10: Release v2.2.1.1 · njz3/vJoy · GitHub

As declaimer: while I understand Github to be generally safe, I’m hardly an expert in these thing. As this software is something that affects your system (it installs drivers for virtual controllers) definitely scan the installer beforehand with your anti-virus and keep your anti-virus shield on during installation. There’s nothing that’s intended to be wrong in these installations, but it’s a sensible precaution.

After installing go to C:\Program Files\vJoy\x64 and open vJoyConf.exe. You should see something like this:


This indicates there is a single virtual controller active and it’s set with 3 axes, 0 buttons and 0 POV hats. The actual number of functions it’s set up with doesn’t really matter, just as long as there at least a single axis. An active virtual controller should be automatically created, and technically you could skip this step.

The virtual controller should also appear in Windows game controller interface:


Download Joystick Gremlin (13.3): Releases · WhiteMagic/JoystickGremlin · GitHub

There is no need for installation, simply unzip the archive somewhere. Run the joystick_gremlin.exe.

Select the controller, then select the throttle axis (it should be automatically selected if you have the controller selected and then move the throttle lever). You then want to add a remap function to the axis, press the circled “Add” button to do so, then configure the remap as pictured to remap the throttle axis to an axis on the vJoy device. Save the profile and activate it by pressing the game controller icon so that it turns green.

Launch MSFS. Note that you need to keep the Joystick Gremlin running on the background with the profile active.

In MSFS unbind your controller’s throttle from any function you have assigned it to. Then select the vJoy device in MSFS (which should detect it as just another game controller). Then assign the vJoy axis you remapped your throttle to into the game’s throttle axis by selecting it from the drop down menu:

What’s happening here then is that your throttle axis is being “faked” as being an axis on a completely different controller. Since the issue might be related to a game setting error pertaining your particular controller (especially since it persisted on identical one) this might bypass the issue.

Thanks again for your help. I have another update…
It is not just the throttle. The rudder is also erratic. If I use an outside view and push the rudder either way it goes but fades back to neutral almost immediatly.
Another thing. I have a friend who I borrowed the stick from to make sure it wasn’t my hardware.
His is doing the same thing. So different computer with completely different hardware and the only thing the same is the thrustmaster hotas x which is a relatively inexpensive stick but has full functionality normally and has been fine until recently.
The only conclusion I can come up with is the latest update has messed with that particular piece of hardware.
I can try out your “fake” solution but really feel this shouldn’t be necessary with a mainline piece of hardware.
Frustrating to say the least

Tried rise of flight and everything works as it should…

Here we go. I bought the T-Flight rudder pedals to give myself a more realistic experience and hopefully solve the rudder issue. Unfortunaltly it didn’t do that so now I’m out more money and still cannot fly. These rudder pedals come highly recommended. If I go to an outside view and push the rudder pedal it moves like it should but won’t stay there. It deflects fully then fades back to neutral while hold the pedal fully. I can’t steer the plane on the ground. i disabled the rudder control on the flight stick to make sure it wasn’t interfearing… So don’t know what to do or where to go. I have a game that I very much love to use but can no longer use it. Any help would be greatly appreciated.
I have also unintalled the game and reinstalled 3 times now. Each time takes days.
Wondering if it’s possible to remove whatever is saved in the cloud? I’m guessing it’s pulling down some settings that I don’t want… Like a complete start over with my profile or whatever…
The other strange thing is my friend is having the same issues with the same flight sticks.

I’ve also downloaded the two programs but cannot get the game to recognize the throttle… I remapped the Z axis and named it then in FS2020 I disable the throttle in the T.Fight and go to the Vjoy to add it but cannot get a response at all… maybe doing something wrong

Worth noting @DocileZulu36368 was reporting seemingly identical rudder issues in another thread (with different set of pedals). Did you try to route the pedals through your HOTAS or standalone via USB (there should be an RJ-USB adapter somewhere, at least if you bought them standalone).

But in any case:

Your peripherals work fine in another game.
Repeated and thorough installations don’t help, in-game workaround don’t seem to work either (e.g. making a new blank profile).
Problem persists with different (if identical) peripheral.
Other people seem to have similar issues.

I suppose you could check your USB ports (try different ports, don’t use unpowered hubs), but I think you have more than reasonable grounds for hardware related bug report here, this particular subforum is for assistance by fellow members of community. The official support channel is here:

Make sure to follow this part carefully:

“Select the controller, then select the throttle axis (it should be automatically selected if you have the controller selected and then move the throttle lever). You then want to add a remap function to the axis, press the circled “Add” button to do so, then configure the remap as pictured to remap the throttle axis to an axis on the vJoy device. Save the profile and activate it by pressing the game controller icon so that it turns green.”

After activating the profile check the Joystick Gremlin’s input viewer (tools > input viewer) that the vJoy axis is working properly. In MSFS be sure to manually select the vJoy axis rather than trying to bind it via actuation (your original controller axis is still working, so MSFS would be confused by the double input).

Another possible workaround would be to use controls management program like Axis and Ohs and These are payware programs that work by interfacing with the sim via SimConnect and bypass the regular control bindings. does have two week free trial.

I just keeps getting worse. I think I need instructions on how to start from scratch and delete EVERYTHING… I purchased a whole new flight system Thrustmaster T16000M and I now have the same problems.
Everything works as it should in a different game as well as in the windows game console. All axis and buttons etc.
When I go to the profile and set it up so that there are no conflicts it even looks fine there. When I actually get into a plane the throttle works for a minute then stops responding. If I am looking at the engine indicator on the bottom of the screen the little arrow that is supposed to indicate where the throttle is set to just flickers but doesn’t move.
I got the vjoy to work but it does the eame thing. I can set it up in the profile and it looks good till I launch a plane.
I have uninstalled and reinstalled and this is still happening.
I thought I deleted all my profile stuff and uninstalled and reinstalled but obviously something is stll amiss…
I uninstalled and searched for anything I could find on the hard drive related to FS2020 and reinstalled without solving the issue.
Please there has to be something I can do to get this working. Seems it’s working fine for other people. My PC works perfectly with everything else on it. No glitches or lockups or anything weird.

1 Like

The whole point of the vJoy experiment was to check if a different device than what you used would work. If T.16000 doesn’t work then it would be unlikely the vJoy would and vice versa. I’d recommend returning the T.16000 if you still can.

Unfortunately I can’t help you on that. To begin with I don’t have the same installation as you do since I have the Steam version.

Principally I’d recommend you to file a ticket on the official support channel at the Zendesk, linked to in the previous post.

The only remaining workaround I can offer is to try controls management software that interfaces with the sim via SimConnect, bypassing the game’s controls interface. Personally I use Axis and Ohs for this (I normally route all my flight peripheral controls through it, my MSFS profiles being blank), others use which I’d recommend to you instead due to two week free demo period, which might get you by until you can find more fundamental fix for the issue. The idea being here is that you would re-route all your axis based commands through the program. I believe there are also some free alternatives, but I haven’t really explored them.

Well I made out a ticket and they said maybe the cloud based profile is corrupted and they sent me a link to be able to reset that.

That was exciting news so I went throught the exercise but it did not fix the problem.
Anyhow thought I’d share this with you for future reference.
I did wipe out all my logs etc and all memory of planes and airports I’d used. I had to go through the basic startup sequence.
Not an issue for me as all I’m interested in is getting it to work.

I think the problem is finally solved. W
What I did was in this order.
I used the previous post to go to a cmd prompt and delete or reset the cloud data without the sim running
Then I uninstalled the sim from the app centre of Windows.
Then I checked to make sure the folder in user\appdata\local.. was gone completly
Then I reinstalled the sim and everything seems to be working as it should.

Thanks for all the help…

1 Like

Glad you got it working. That was certainly a hair-raising one.


None of the above solutions worked effectively for me.
Here’s some of my findings on this issue, or closely related issues.