Thrustmaster TCA Yoke Pack Boeing Edition Button Assignments

Thanks Nixon, I have the controller off. I use a keyboard and mouse. I re-mapped some of the functions on the boeing yoke and quadrant just for the cessna 152 and saved that profile. It doesn’t matter what profile i use though…the same thing happens. My son suggested that I just unplug the yoke and re-plug it back in whenever the glitches happen and surprisingly that works although its a PITA. If they go funky mid flight i just ESC out and un-plug wait 30 seconds and re-plug and hit ESC again back into the flight and they work again…beyond frustrating.

Do you have access to a PC?

If so, go to Thrustmaster’s website and download both the driver installation for the Yoke pack and the separate one for the TPR.

Once you’ve run both, the firmware tool will allow you to update the firmware on all the peripherals. See if that helps.

There were firmware updates for all of them when I did this.

Just so I understand, too. You have the pedals plugged into the throttle quadrant and the quadrant plugged into the yoke and, finally, the yoke plugged into the Xbox?

It’s weird, your issue almost sounds like a low voltage issue with USB.

Yes sir… plugged in that way. I looked last night and I was pretty sure the updates were from late 2021… My yoke just got here a week a go or so… I was assuming that is what they already had… but I’ll check again. I’m not a computer guy so I don’t know about the low voltage thing. I can read up on plugging it into my PC and see what happens with that… Hopefully with the forums help I can get it figured out.

That 2021 file is the one you want. Don’t be fooled by the date. It can download and update the latest firmware.

Thanks again… I’ll give it a try and let you know how I make out.

1 Like

I have not found this to be the case.

For instance, I have assigned mine in the following manner:
• IAS/MACH (49) + SEL clockwise (53) — Increase COM1 (Whole)
• IAS/MACH (49) + SEL anti-clockwise (52) — Decrease COM1 (Whole)
• HDG/TRK (50) + SEL clockwise (53) — Increase COM1 (Fract)
• HDG/TRK (50) + SEL anti-clockwise (52) — Decrease COM1 (Fract)
• IAS/MACH (49) + SEL push (54) — COM1 Swap (this is listed twice I use the second one, the first one doesn’t work)
• HDG/TRK (50) + SEL push (54) — COM1 Swap (same, but as the alternate assignment)
• Altitude (51) + SEL clockwise (53) — Kollsman Increase Altimeter
• Altitude (51) + SEL clockwise (52) — Kollsman Decrease Altimeter
• Altitude (51) + SEL push (54) — Set Altimeter to MSL Pressure

Like this, I can use the IAS/MACH and HDG/TRK to tune my COM1 radio and press the SEL button in either case to swap frequencies.
Likewise, with Altitude, I can adjust the altimeter and set to 29.92 with the button press.

I’m sure there are other ways the knob/selector could be configured, too.

1 Like

Hello, sorry for my noob question - all these seetings are to be done in game controllers settings in Windows ? Doesnt WIndows set it all autoomatically?

I have just bought the boeing yoke set with two quadrants and I am a liitle bit confused with calibration of the quadrants in MSFS2020 . Couldnt you make a short movie in YT?
Greetings

When you connect the yoke and quadrant(s) to the Xbox and/or PC, they will have a default set of keybindings as set by Thrustmaster.

In other words, they will work right out of the box and can be used straight away.

However, if you want to reconfigure them to how you would prefer they operate and/or gain more functionality from them, you do that from within the sim itself, not Windows.

If you are on PC (or of you’re using the sim on Xbox and have access to a PC), the Thrustmaster drivers also install a Control Panel and a firmware updating tool. The Control Panel, really just allows you to check the behavior of the yoke and/or quadrant(s) to ensure their buttons or axises are operating. There is a calibration function there for some of the axis, as well.

According to Thrustmaster’s documentation there really isn’t a separate calibration to be done with the quadrants. It states that to calibrate them:
• Power off PC/Xbox
• Unplug them from PC/Xbox
• Plug them back into PC/Xbox
• Power up PC/Xbox

Regarding YouTube — I’m a reader, I dont watch TV and really never have, and seeking information from video frustrates me. I can quickly scan through text and find the information I’m looking for in far less time, and with more chance of success, than I can sitting through an entire video in the hopes that said video will actually have the information I’m seeking. I can also bookmark that text and easy refer to it again and again without fumbling through fast forwarding video. My experience with it is 80% frustration to 20% actually useful.

1 Like

this was very helpful. thank you!

1 Like

I am assuming this only works with a PC. How can I do this with XBox?

Are you asking about performing a firmware update? If so, you’re going to need access to a PC.

I’ve found no way to update them via Xbox.

I was trying to refer to how you assigned the buttons on the second quadrant. If doesn’t look like that can be done with the Xbox.

Having reread through the whole thread, I now understand your reference to a firmware update. What I understand you to be saying is that if I have access to a PC, ThrustMaster provides a tool that facilitates making the assignments to the three selectable buttons on the second quadrant.

You can absolutely assign the second quadrant buttons on Xbox.

I’ve got the three-way knob when pointing to IAS advancing/decreasing whole number frequencies with the SEL knob on COM1, pointing at HDG with SEL advancing/decreasing fractional on COM1, pushing SEL swapping COM1 frequencies. When set to ALT, SEL knob increasing/decreasing Kollsman and pushing SEL to set STD baro. I’ve got the lower left and right buttons for reset rudder and toggle tail wheel lock.

If I hold the left trigger, then the IAS/HDG/SEL combination advances/decreases\swaps NAV1’s whole and decimal frequencies instead.

(Oh, right, I’d mentioned most of that above earlier in the thread)

I’ve got so many button assignments via the entire yoke and two quadrant setup that I rarely even touch my keyboard.

You def do not need a PC nor access to one to do any of that.

See:

Hi, how to setup bottoms for pmdg 737:

  • gear up/ down default config infortunately doesnt close the gears nose,
  • toga/ auto throttle - after switch toga autothrottle is disengage

Thx in advance,

Hi, just created an account.

First off, thanks for sharing the button mapping.

Here is my problem. I have bought the TCA boeing yoke pack. I had played around for hours and hours until I had learned which button corresponded to the options and set everything up. The only thing that does not work is the rudders.

When you play with the controller, all is fine. When my yoke and quadrant is plugged in with it’s own configuration, no matter where i assign the rudders, it will not work. Nothing is fluid and it is impossible to taxi and complete the flight training programs. Can someone help me to avoid buying the rudder pedals for now?

TIA,
Alec

You need to assign the rudders to an axis, otherwise they will behave in a binary on/off fashion.

As I’ve always had pedals, I’ve never tried the yoke without them.

Have you tried assigning the rudders to the right thumb hat’s X-axis, for instance, and seen if that works?

Hi,

Yes I have tried assigning them an axis and just a button layout. No luck. The axis makes them stutter and basically renders them useless and the button works but makes the rudder go completely to one side and does not come back and center so impossible to taxi as it stays blocked.

Hi. I really appreciate your list. I just got my TCA Yoke pack for my Xbox x today and I’m already really frustrated. I just have one throttle quadrant, I want to have the left axis be my speed brake , the center axis to work engine 1&2 and the right axis to be flaps. Each time I go into the control setting and try to assign or search a input (like one of the axis), it displays multiple inputs and freezes. I have to quit MSFS and relaunch.
Has anyone custom assigned flaps to axis 12? Or assigned both engine throttles to axis 11?
Has anyone experience freezing when try to “find” an input by actually moving quadrant lever. I really hope I make sense. I am trying to quadrant I’m having difficulties. Nixon, have you made a YouTube or other video showing different mappings? If not, would you?

I’m not a video person. I can’t stand it as a learning reference, frankly.

I have found that sometimes there are control axis on the peripherals that input when trying to use the “Start Scanning” function of the control assignments.

That said, here’s what I’ve found with my setup:

• throttle quadrant axis when not fully at a stop will sometimes register as an input. Try firmly putting them at a stop before initiating the scan.

• throttle quadrant 3-way selector knob will sometimes register when scanning. Move the knob to a half-way position between one of its three settings before initiating the scan.

• TPR pedals will register an axis when scanning. Disconnect the pedals prior to initiating the scan.

Lastly, I’ve sometimes had to set axis dead zones to fully dead to completely disable them from registering when scanning. Just don’t forget to put them back when you’re done doing assignments.