Tip to prevent unintended cockpit zoom while turning instrument knobs

Yes, you can also assign zooming to RH mouse key in combination with mousewheel

I would like to do that . But scan does not detect the mouse wheel.

Well, only for zooming out…MS/ASABO didn´t added a zoom-in function, so far I could see it !?
Do you have maybe something different in your settings?

See the screenshot in my first post above, and make sure you set the filter to ‘ALL’

Funny…I was needed to change to EN-US, because is German this one for “unzooming” has a total different label :sweat_smile:
However, thanks now I got the function I was looking for and zomming in/out is working in combination with the RH mouse key, but…here we go again…it doen´t work together with "toggle cockpit view freelook (hold), or the other freelook toggle funtion :thinking:
Meight that be possible? (see my picture)

EDIT:

I found now my solution…I just entered the “toggle freelook (hold)” onto the right row within the setting.

2 Likes

I have an old USB button-box I use for iRacing. It has up/down toggle switches, push buttons and rotary dials.

Can “one” of the rotary dials on my button-box be a designated “knobster” to control any “selected-knob” on the dashboard?

Kind of how Flight Manager works where you select the dial to adjust, then use the button-box knob.

My DSD Button Box seems to be working just fine. I was able get the buttons, dials, and toggles to do what I wanted so I am set!

I did have to un-plug the USB cable “in-sim”, on the controls window, for the sim to set it and populate the different actions that could be applied to each button.

Yes and you can always set both methods, by setting one as primary and the other as alternate assignment. That way you can use either method which is the most convenient depending on the situation

Sorry about my previous post, it was for another thread but yes, I’ll look into how 2 setup the alternate. Not exactly sure how to go about it but I’ll try and figure it out.

What is the difference in moving the right click to the alternate column?

I’m trying to apply this solution but no matter what I do I can’t seem to add mouse mid click + wheel up / down to cockpit zoom un-zoom. If I clear the current input it shows “start scanning” in grey letters but its not detecting any inputs on my mouse when I scroll or click buttons.
If I use the drop down selection list I can choose a mouse button or the wheel scroll but I can’t add 2 functions via the list.
Previously when customizing my Alpha yoke flipping switches on the yoke wouldn’t auto-populate for the chosen function and I had to use the selection lists.

Am I missing something regarding the simulator automatically scanning for inputs to bind to game functions that have been cleared or not assigned? Can’t figure this out.

Are you sure you have selected mouse on the top? I have just done it via scanning, worked perfectly.

I tried it and it works great! Thanks :wink:

Yes I have the mouse selected and mouse buttons are showing in the drop down select list. However I can’t get scanning to work so I can bind a button + scroll to cockpit zoom.

Scanning is started by clicking into scan field. Don’t move mouse otherwise that is assigned.

1 Like

That was it!

When I’d clear the input and try to activate scanning it kept inputting x-axis mouse movements instantly.

Turns out its ridiculously hard to hold a gaming mouse still while clicking a button and scrolling. Took about 20 tries to get the button scroll combos added for cockpit zoom / un-zoom. Working as desired now. Thanks for the tip.

1 Like

Glad to be of service. :wink:

no need it if u set zoom on you joystick !

The TRICK is move the mouse pointer to the scan select box, and then lift the mouse up, and click-- then you can scroll & right button press, but because the mouse is up in the air, you cannot get an interfering mouse MOVEMENT input …

Works every time !!!

You must be a surgeon.

1 Like