Tobii 5 Eye Tracker - Stops Working in Windowed Mode (When Window Gets Minimized)

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

Yes

Brief description of the issue:

Tobii 5 eye tracker works, except when you go from fullscreen to windowed. It stops working all together; no longer shows in peripherals.

I am able to repro this by making the sim go in Windowed mode, then minimizing the window and re-maximizing the window, then Tobii stops reacting/goes away in controller settings.

Provide Screenshot(s)/video(s) of the issue encountered:

Can’t provide screenshot, but have repro’d this several times.

Detailed steps to reproduce the issue encountered:

Ensure Tobii is working, go from fullscreen to windowed mode in settings, get back into sim – Tobii no longer responsive.

PC specs and/or peripheral set up if relevant:

i9-12900k, Windows 11, 3080 Ti


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

No problem here when switching full/windowed. But Tobii tracking can act weird at times, where it just doesn’t work (happend in SU9 and maybe before also)

1 Like

No one else w/ Tobii having intermittent issues – the sim won’t even recognize I have it some times, so I have to restart the sim and then it works fine.

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes, same issue - Tobii Eye Tracker 5 stops working after minimising/maximising in window mode and disappears from the control options

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

1 Like

Do you have the same issue if you follow the OP’s steps to reproduce it?

I do occasionally have this myself

Provide extra information to complete the original description of the issue:

Weird thing is, if I power down the Tobii and turn it back on, the sim doesn’t pick up on it like it will do other peripherals.

If relevant, provide additional screenshots/video:

1 Like

Do you have the same issue if you follow the OP’s steps to reproduce it?

yes

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

1 Like

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes

Provide extra information to complete the original description of the issue:

On occasion, going from windowed to full screen or vice versa stops Tobii from working. Only restart of the game restores it.

If relevant, provide additional screenshots/video:

1 Like

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

I have exactly the same issue.

This issue is still happening. Any updates Asobo or Tobii?

I tried using Tobii and changing the Sim from Full to Windowed mode from within the settings menu, rather than using the Alt and Enter keys, did not result in a Tobii issue. It takes longer of course. So I wonder if the Alt and Enter keys are causing the problem. It also seems as if the problem is intermittent, as my last flight was faultless, while during the previous flight Tobii failed.

In Sim Update 10 beta, for me, I don’t even have to do Alt-Tab – I just minimize the window, re-maximize the window and Tobii stops working.

I have a theory, not yet tested, that if you disable tracking in the options menu or using a shortcut key and then change from Windowed to full screen and back Tobii will continue to work. I will test this later today. Whatever the cause it is annoying and Tobii is the only external MSFS hardware that has this issue so you would imagine that they would keen to resolve it and issue a fix. It’s disappointing to hear that it appears to still be a problem in the forthcoming update.

I’ve my theory on two flights and so far no problems. Therefore:

1 Assign a keyboard, or joystick button to TOGGLE HEAD TRACKING.
2 Toggle head tracking Off before changing from full screen to windowed view and then Toggle head tracking back on when needed.

So far this has worked. No guarantees given though.

I haven’t tried some of the windowed/fullscreen fix attempts yet, but I am having a similar issue with Tobii not working at all.

Below is what I posted over in another Tobii thread:

I own an Alienware laptop with the embedded Tobii in the monitor bezel.

At some point around mid-July, shortly after this thread was opened, I noticed that my Tobii eye tracking was not working in MSFS. The eye tracker no longer shows up as a controller in settings and no head tracking works, regardless of camera settings or F12 tracking resets.

I cannot recall if this correlates with my install of the SU10 beta.

Tobii software and drivers were completely wiped and reinstalled using the appropriate drivers for my hardware. This did not alleviate the issue. Eye tracking works under Tobii Experience and Windows Hello but MSFS does not seem to recognize hardware (or at least does not populate a controller for it).

Tobii service log does show the following info about a client connection:

2022-08-31 xx:xx:xx,xxx [16] INFO Tobii.Service.Plugin.TobiiPluginManager -
Stream Engine: Client connected: FlightSimulator
2022-08-31 xx:xx:xx,xxx [16] INFO Tobii.Service.Plugin.TobiiPluginManager -
Stream Engine: Client 26 connected for server 1

I haven’t really had time to bother with it recently but I think I’m going to dedicate a little time to troubleshooting. Once I get a chance I’ll do some tests to see if I can get it working, then test windowed vs fullscreen vs minimize/open tests to see if these further issues persist.

Troubleshooting update: I performed several tests, including an uninstall and reinstall, tests with no addons, etc. I have a laptop with the embedded Tobii.

When running MSFS on the laptop display, the Tobii device is recognized, shows up in controls options, and works beautifully. No issues if I leave MSFS on the laptop display.

If I start MSFS on my external monitor attached via displayport, the Tobii is not recognized, doesn’t show up in controls options, and will not be recognized no matter what I do.

If I start MSFS on my laptop monitor then move MSFS to my external, Tobii will work while on the laptop display and then disappear from MSFS once I move it to the external monitor.

This is not the same behavior I experienced prior to installing the SU10 beta, so it seems related.

This issue has not been fixed as of the latest beta update.

I just got Tobii today and am experiencing the same issue. Why isn’t there more people complaining about this? I’m pretty worked up right now as I need to be able to minimize the sim. Ugh. Went from 10 years operating on TrackIR flawlessly to this nonsense.

A guess one pertinent question is: “Are there any Tobii 5 Eye Tracker Users, who are not having this problem?” I have tried putting the TET5 on two different systems, one with SU9 and the other with SU10Beta and both do the same.

As a work-around, I have been running in windows mode, but instead of minimizing MSFS to run another app, I scale the MSFS window down and then move it partially off the screen.

Do you have the same issue if you follow the OP’s steps to reproduce it?

YES

Provide extra information to complete the original description of the issue:

Just go to HW profile, minimize MSFS and maximize. Tobi Profile disappears like Houdini. Needs a full sim restart to fix.

If relevant, provide additional screenshots/video: