Toolbar broken in VR

You’re not alone not being able to hide the yoke or stick in any aircraft. It’s annoying but they’re still flyable. The view change when you activate the mouse using LCtr+0 makes flying the FBW A320 virtually unplayable however. They’ll get it fixed in time hopefully.

It’s fixed in 1.21.17.0 my dear VR users. We can finally use the mouse. :star_struck:
But Oculus touchs are still not working for the C152 cockpit (dunno about the others), I just can’t interact with anything, only with menus and pop up windows.

Better than nothing I guess.

4 Likes

With the same problem. In addition, the learning menu does not allow the mouse to hide the yoke - so you can not continue with the tutorial

I thought the new version was not available till Monday 12/6/2021.

Is there a way to get it today?

1 Like

I’m trying too… but today MSFS is not even starting. Black screen, program frozen, nowhere to go. Closed yesterday that was working, dead the morning after. Great update this last one :roll_eyes:

Found that the patch is beta… 1.21.17.0

I am confused… we have a non working function in VR… critical. But yet there is a beta that fixes this in the production release? I am confused… doesn’t this stuff get fixed in a beta before it hits main stream?

Someone goofed up you say?

People who took part of the previous beta test could install the update since Friday.

I’m missing something… how? I was in the VR beta, but I don’t see how to access to these patches.

https://forums.flightsimulator.com/t/new-pre-release-testing-information/478474

Only SU7 beta testers can access the link.

ahh I was going to say, I get an error saying that it’s private :smiley:
So it’s another beta, not the VR one. I see…

Toolbar access seems to be solved in 1.21.17 beta

1 Like

We are now closer to a fix happening next year than a fix at the date it went wrong!

True but a new bug has been introduced that stops control inputs working i.e. throttle etc when the mouse is over a toolbar window. This is almost literally unbelievable and a real pain in the ■■■.

1 Like

:joy:
I don’t what to fall in the usual error of thinking that everything is really easy… but it does indeed look like something not too complicated :sweat_smile: at least once you had it already in place and working fine.

1 Like

Please log the bug in Zendesk and open a bug thread so we can vote for it if not done already because this is an issue that not everyone will encounter. :slightly_smiling_face:

Yes indeed. Seeing this too. Also when the mouse is on top of the opened windows like atc, no control Inputs possible then.

I think this will affect all VR users. If I am wrong then it will be really interesting to see how the systems of those affected differ from others.

I have just flown some further test flights in a plane I am not so familiar with. A simple circuit in the cub crafter. On final approach, I moved my mouse to the ATC window to announce on final at this un-towered airfield. inadvertently, and as I have done a thousand times, I left my mouse over the window. On approach I throttled to idle but unknown to me, throttle stayed at about 20%. I didn’t lose airspeed and floated right to the end of the runway before I realised what had happened, and attempted the landing too late and crashed.

I am annoyed that this is happening and don’t want to have to learn a new trick (move mouse away from window) when I really shouldn’t have to.

I hope this is fixed soon.

I don’t have this issue with a X1 gamepad, that’s why I was saying this.
For me, if I use the mouse but touch any button/yoke, the mouse pointer goes back to my view center but buttons/yoke work fine even if I leave it on a window/top bar (since it moves back to the center anyway).

  • The issue is that if I want to use the mouse, I can’t touch anything else or my mouse pointer will keep moving to my view center and therefore, make any interaction impossible.
  • Oh and another issue is that if I move the mouse and then touch the left stick (yoke), the mouse pointer (that goes back to my view center) transforms into a big white dot. :grin:
  • I also can interact with any instrument with the center of my view because even if the white dot is usually not displayed, it still exists.
  • Oh and a last one for the fun of it: If I focus on any intrument (blue highlight), and move the right stick (that usually moves the view in 2D), well it works like in 2D and moves my head and breaks the reset function (reset view will then become where I moved the view with the right stick).

I think that this is far from being over and there is a lot of issues that are piling up. :sweat:
They implemented something but didn’t think of (and tested) any edge case.

2 Likes

Yes,

The 1.21.17 patch that’s in public beta seems to have fixed it, at least for me.
Follow the indications in Pre-release Testing - SU7 Update Public Flight - #2 to get the patch (at least for a while) until it goes to production.

If you used the “Home cockpit” trick, you should change it back in order to get full functionality in the beta.

The public beta patch works for me too (7 Dec)

o Set:

  • General Options
    • Camera
      • Home Cockpit Mode = OFF

o ‘VR - Camera Reset’ button works

o Toolbar responds to mouse clicks