Toolbar Missing after exiting SU13 Beta

:wave: Thank you for using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

No

Have you disabled/removed all your mods and addons? If the issue still occurs with no mods and add-ons, please continue to report your issue. If not, please move this post to the Community Support section.

Yes

Brief description of the issue:

Toolbar has stopped appearing at top of screen (drop down toolbar). I reverted back to the public build of the game after experiencing issues with SU13 Beta Versions.

Provide Screenshot(s)/video(s) of the issue encountered:

N/A - tool bar at top of screen is not visible on any flight

Detailed steps to reproduce the issue encountered:

Load a flight, tool bar does not appear when mousing over area.

PC specs and/or peripheral set up if relevant:

i712700k, 2060super, 32gb DDR4 CL16/3200mhz, 2tb NVME

Build Version # when you first started experiencing this issue:

1.33.8.0


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

I understand that you may want MSAsobo to reply to this and actually resolve this issue, and if that’s the case then you can ignore my reply. But if you want to give this a shot, these steps are what I follow when I’ve been in the beta and I need to back it off for whatever reason. I’m a Steam user, but (I assume) these steps should work for both.

Of course you’ve already removed yourself from the Beta, so the next step is to exit MSFS if you’re in it. After that, delete all fs-base and fs-base-ui folders. Restart MSFS and it should re-download those folders - see if that resolves your problem. Obviously not a guaranteed fix, but I have done this a lot and it’s worked well. Best of luck.

5 Likes

appreciate your input - you’re saying to delete all the folders in packages then?
image

No, not exactly. This is where I navigate to:

Screenshot 2023-08-12 115656

And these are the only four directories I delete:

Of course my installation may be different than yours, but once you’re at the ‘Steam’ level directory, it should be the same after that. Once you’re there and delete those directories, when you restart MSFS, (assuming you have removed yourself from the Beta in your Steam configuration) you should then get a new installation panel wanting you to re-install those folders. After that, you should be off of the Beta.

6 Likes

@ Trex2269152
If you’re talking about this toolbar, the same thing is happening to me. I’m still in Beta 13.

No, not talking about this tool bar, for me it’s the “eyebrow” drop down one that you mouse over at the top of the screen while flying (where the weather, w+b, etc panels are).

1 Like

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Thank you for this possible solution and for the OP to raise the issue. I also left SU13 beta due to loading issues, and deleting those 4 fs-base directories helped me (having the MS Store version, not Steam). Had to re-download 8.30 GB.

1 Like

After deleting those four directories, did you just relaunch the sim right away? Or verify the files through steam first to prompt a download?

You don’t have to verify anything through Steam - actually, MSFS does the heavy lifting here so to speak. After you exit the Beta in Steam and delete the four subdirectories, the next time you start MSFS it will sense that the four directories are gone and will download them. Since you’re no longer in the Beta, it will download the non-Beta code and you should be set.

Let me add that this may not fix your toolbar problem, but at this point, the only other possible solution I can imagine would be to uninstall MSFS from Steam and download it again - and you really want to save that as a last resort.

2 Likes

I do not have the steam version, as mentioned…I restarted the sim straight away.

I noticed the same problem this morning. After deleting those files, I have 16.8GB to download again, which is in progress now - hopefully this will correct the issue.

EDIT: After the above, the missing toolbar problem was corrected. Kudos to @DestructZero915 for figuring out a solution.

3 Likes

I’m having issues even locating those four folders, where did you find them? I go into my packages directory, there’s no “official folder”, just a couple of ui folders that have different names, about six of them.

Navigating to here: E:\SteamLibrary\steamapps\common\MicrosoftFlightSimulator\Packages
shows me this:
image

EDIT: I found the packages @DestructZero915 mentioned above here: DRIVE:\SteamLibrary\steamapps\common\MicrosoftFlightSimulator\Official\Steam. Not sure why they were there, but maybe it has to do with having the sim installed on a seperate dedicated drive (non-default install location). Sim is updating now, will report back if resolved!

I have the MS Store version, and I’m using a custom install path as well, so my folder structure is different from Steam players.

image

image

image

Thank you for this!! I had the same issue rolling back and this fixed it. Only took about 25 minutes to update vs a couple hours for a full reinstall.

1 Like

Confirming this has finally resolved this issue for me as well. Major thanks to @DestructZero915 for their solution, awesome contribution.

Thanks all and blue skies!

2 Likes

I want to add my voice to the chorus of those who lost the toolbar with the beta. I withdrew from the beta due to stuttery performance on a 4090. But when I reverted to the current, already-release version, my performance was back to normal, but I still had no toolbar. Hoping to fix things by using Windows Restore totally crashed MSFS, and I needed to do a complete reinstallation. All is up and running beautifully again. But this beta is not among my favorites.

1 Like

On the Beta still and I only sometimes don’t get the toolbar.

Left the beta as well and had the same issue. Thank You again for posting this solution. It should be pinned for the purposes of leaving this specific beta if you asked me because anyone leaving the beta is probably going to be presented with the same problem.

1 Like

Same here. Left the beta and lost the toolbar at the top. I’ll try the solution described above. Thanks for that!!