Track IR Stops Working

OK, I have tried assigning Ctrl+H to Toggle Head Tracking - does not work. I have also tried assigning Toggle Head Tracking to a button on one of my controllers and again - no luck. The only way I can re-enable Head Tracking is through the in-game Toolbar. Any ideas please?

same issue

You are very lucky, I don’t even get the option in the camera in game menu, the LEDs stay on but MSFS doesn’t know that I had a TIR connected and working. We will have to wait…

Working ok for me!?

I don’t get it! I was really nervous to boot up the new updated version of MSFS to find Track IR would not be working… but it works JUST FINE!

I tried to move head around all over the place like way down, turn around etc and track IR did not freeze. Seems like before the update the movement would freeze, and I would need to re-center pressing F12. My pause key is F9 and I can move my head to “zoom in” on the panel and press F9 to pause. I can easily re-center using F12.

The only steps I took was a full reboot after update (like I ALWAYS DO) - then I started up Track IR, then start up MSFS.

In Track IR my center key is programmed as F12. Pause key is F9.
In MSFS to activate or start using track IR the default key is CTRL F12 (which I left as is). Started sim, pressed CNTRL F12 and no problems at all!

What version of Track IR you all using? I’m running 5.4

1 Like

That’s exactly what is does. I can’t fly now. Please fix this ASAP

3 Likes

Agree with your sentiment. I am doing the same thing, definitely nothing from the marketplace for me until this bug is solved. But as far as I know Microsoft do not get a cut from things we buy outside the marketplace, so I think you can get those Aerosoft products if you want.

4 Likes

Don’t know if this has been mentioned yet or not, thread has gotten pretty long and I’m not going to read 200+ comments, but I found a default bind in the control options for “toggle track ir”. No idea if this has always been there or if it’s new? But assigning this to a key or something works and at least keeps from having to open the camera menu. The release notes mentioned something about f12, but this was not bound (at least not on mine) to that or any key by default.

@TIYCaS,
See this post above:

A post was merged into an existing topic: Xbox Series S/X Headtracking

What Asobo need to do is to hand back control of TrackIR to the TrackIR software and get rid of the option to control TrackIR from the MSFS toolbar. TrackIR worked perfectly before, it wasn’t broken so it didn’t need to be ‘fixed’.

7 Likes

For anybody who is having problems getting the “Toggle Head Tracking” to work with a button assignment - check that you do not have “Home Cockpit Mode” turned on. This is found in General Options - Camera - Cockpit Camera.

1 Like

Why should I be made to give up home cockpit mode to use TrackIR???

It worked perfectly well before SU7

2 Likes

Where is this “toggle track ir” bind exactly? I only find TOGGLE HEAD TRACKING which does not work.

I posted this as temporary “fix” so that people can assign a button to Toggle Head Tracking. This had me stumped for all of today about why the button assignment would not work - others may be struggling the same.
I do agree that this “bug” needs to be fixed properly though.

Will it still work if you revert to Home Cockpit Mode after assigning the button?

Not on my system. Home Cockpit Mode seems to have an effect on what the Cockpit Camera system can do.

OK thanks, not a workaround for me then.

Oh my fault, it is toggle head tracking. Works for me though, not on f12 though. Had to use a different key. The actual variable im seeing in spad is A:TRACK IR ENABLE if you don’t use the sim control option.

1 Like

Thanks for clearing that up.

I can’t get any key bindings to work with TrackIR like they did before SU7, and I am not willing to give up Home Cockpit Mode to work around it.