Trim Bug - Trimming not possible

The CJ4 is impossible to trim now

1 Like

Hear him, hear him. Thanks for reply Dude!

Go to the head ( my Post) of the reports and click on left site the blue button “Vote”. Thanks for Support!

They are canceling great sh*t out of the sim, and creating more creative sh+t in the sim. :smiley: Think about, MS will let them pay penalty for “unreasonable troubles…” :smiley:

1 Like

Nearly every plane. Expect: DA40DGN, but only to +50 and -50 lol. But whatevery, you can fly and keep control :smiley:

I have the same thing with my X56 and thought I just was seeing wrong. Plane would continually dive. I thought it was the flaps or some other input but I get no response from my trim wheel.

I’m using a combination of Thrustmaster Hotas on the left and Logitech on the right. Gas lever on the left and Joystick on the right. I almost always fly the Icon 5, in the vicinity of where I live. And before yesterday, after updating to the latest, I found some modified controls, and as also happens to you, the useless Trim. Now I have assigned two buttons, but neither with it nor with the keyboard, it goes fine as before it did with the left axle wheel

There is also this thread. Maybe the two should be be merged?

2 Likes

no, it says im out of votes and i cannot vote again. but i did not vote something, ever. so i guess i cant vote at all

1 Like

Only noobs use trims! Scream ‘Banzai’ and Yoke you pull!~ :crazy_face:

1 Like

I have a x56 hotas, trim with wheel don’t work.

Bug is gone for me with SU6. Anybody with me?

I still have the trim issue. I have the deluxe package (not on steam). When mapped to my trim wheel (on an axis), the trim will move but re-centers slowly un-commanded. I mapped the trim to buttons on another controller (after clearing the trim wheel controller) and the same thing happens. I have mapped the buttons on the controller for Trim Nose UP and Trim nose down. Honestly, this is getting a little old.

I have the same problem - the trim down now work with the C172 when I am using a trim wheel. It works on other aircraft (including the c172 with the G1000 glass cockpit, but not the C172 with round gauges. This is important because I am taking flying lessons and I have be using the MSFS 2020 as part of my training and practice. I need the C172 with round gauges to work to practice landing, maneuvers, etc. I think something is screwed up with that specific aircraft model that they need to fix. It was screwed up by the 5th update a few months ago.

I have the same issue with the pitch trim re-centering. I only have been using an Xbox controller and have not had this issue before SU6.

The problem I had with the trim on the Icon 5 has been solved…
I’ve checked it right now. And for me, it has already been solved…

Thanks to @lls

For those who are reporting the trim issue as fixed: Which version do you? Are you on Steam? How do you have the trim set up…button, trim wheel etc?

Latest Microsoft Store version, Trim set up to an little whel axis on my throttle (Thrustmaster T16000).

I have the same problem and it is really frustrating and annoying. How is it possible that such a simple feature as trimming does not work? I tested without controls, only with keyboard, the problem persists. My plane (DA 62) always sinks, I trim, then it goes up for a short time and sinks again. Does Asobo read this?

The trim settings are working for me but it’s a half degree off each way, The ailerons have to be adjusted 1 degree left and then right about every few minutes for the entire flight. I’m not a pilot but I’ve been on flights in several small planes and the pilots could fall asleep after they setup the trim. Think Microsoft should correct this issue or dial into my computer and actually show me that they can setup the plane in a timely manner and not have this behavior.