TRIM issue still not fixed since SU5?

Since SU5, in a lot of aircrafts the trim dosn’t work any more with our controls.
Since SU5 there a 2 hotfixes but the trim issue (a major control to fly a aircraft) is still not working?!?! Is this a joke from Microsoft ???
When does Microsoft plan to fix this so that we can fly all planes again? @Microsoft remember we paid money for the game and you broke it. You will at least manage to get the trim back completely within a day or should we wait a month until the next WU and not be able to use a purchased and paid product for as long?


Blanket statements that trim is broken are rarely helpful. Truth of the matter is that YOU have a problem with how you have it set up on YOUR controls. I have absolutely no issues with trim. I have assigned trim to a 4-way switch on my X-55 and it works fine for both aileron and elevator trim. On GA aircraft like the Cessna I can use my mouse wheel on the trim wheel and that also works normally. So saying that trim needs to be fixed isn’t an entirely accurate statement.

What would be important to know is what controller are you using for trim and how to you have it mapped? Perhaps there are other users with the same hardware that you are using that can share how they have their systems configured. If nobody can get it to work with the same hardware then you need to be communicating with the hardware maker.


This isn’t a very helpful way of writing. You should raise a zendesk ticket if you have not done so, with as much information as possible. Without knowing what controls you are using it will be impossible to get any help.

1 Like

I have trims issues though maybe not the same. In the cessna 172 just one press of trim sends me in a dive or steep climb. looking at the trim wheel in the cockpit it barely even moves. Even moving the wheel in the cockpit by mouse it is way too aggressive. last time in an actual remembers much more movement of the trim wheel needs to get such large effects.


please go to the search function and have a look for “Trim broken” and you will find out what I mean. So before you answer that I have this issue look around.
Sometimes it is better to stay quiet and do not answer, than bring only the answer counter +1!

1 Like

Trim works fine here

1 Like

Yes I thought the sensitivity has changed too but I use a Logitech Joystick buttons.
Just 1 click is sometimes too much and nothing can be changed on that.


I’m willing to bet that more people have no issues with trim than those that do. I stand by my original post.


But how does sensitivity work in regards to the trim wheel in the cockpit gui? It should only effect the joystick. I too think it it just to sensitive. I was a little exaggerating a full on dive or climb. But it make it really hard to trim. I find instead of trimming the last tiny bit to stay level I end up adjusting power because I can’t get fine enough adjustment with the joystick or in the cockpit…

Don’t get me wrong but since SU5 there are tons of post about this issue and we all paid a lot of money for MSFS2020. Since the 27.07.2021 the bug of a major control of a Aicraft exists and makes a lot of airce´rafts unflighapble. So I think it is time to write post like this because once again, we paid for this and we paid for a working version.
If a major basic functionality is not working than it must be fixed with highest priority. But since allready 2 hotfixes are out and this basic major functionality is still broken, than it is time to ask in this way.


that is NOT true! I work with the default sensitivity since the beginning!
In some aicrafts it works very well ond on some you can use the trim on a analog controler any more since SU5 but before without any issue

May that this are not fly for example the C172?! Not all fly with the small aicrafts. Most think only big :wink:

Trim sensitivity is way higher, at least on some aircraft like e.g. the 152, and in case of the 152 it’s IMO a tad too sensitive.

1 Like

You are true and with this current BUG since SU5 it hase to be fixed with highest priority

1 Like

I don’t exclusively fly GA aircraft. Mostly I fly either the Working Title CJ4 or the Aerosoft CRJ. It makes no difference what I fly. Trim works normally with my hardware setup.

Yes the Trimfunction in the Cessna 172 Classic is damaged when you use an external trim Wheel (like Saitek). It jumps and makes a strange click sound. In the Cessna 172 G1000 it is okay. It would be great if they will fix it soon.

For the persons who write everything is OK please read exactly. I only talk of the Cessna 172 Classic and when you use a external trim wheel and NOT BUTTONS.

Until simupdate 5 everything worked fine.

1 Like

C172 G1000 trim is ok. Sensitive, but ok. The C172S (steam gauge) though is another story. When you use a trim wheel (like on the Honeycomb Bravo), you hear clicks like a button being activated. Trim applies is huge with each click. It makes the plane difficult to trim and really no fun to try. Shame, because it’s my favourite plane. I haven’t really been able to fly it since SU5.


Do you possibly use „old“ aircraft improvement mods? Not even necessarily for the particular aircraft but influencing it? When for example the DC6 came out I found that Mugz‘ TBM mod interfered with the throttles on my system and I had to disable it when I flew the DC6. The way the community folder works is still an issue in many ways and should always be the first way to go.

If you use FSUIPC or Axisandohs you can set trim increments as fractions of 16384.

For what it‘s worth, the MSFS control assignments are so bad and cumbersome that I generally recommend AAO anyway.

I use neither, but considering looking into them…

I tire of needing 3rd party tools in order to fix Microsobo’s ■■■■ ups.

1 Like