TRIM issue still not fixed since SU5?

The trim wheel on the Bravo throttle works great after the SU5, but it was extremely insensitive before the patch, so I can imagine that it is hypersensitive to other users now.


Trim definitely works, but to get a plane halfway stable using it, that’s another matter and a challenge by itself…lol


Normally you trim for a control force, usually zero. In the sim everything works visually so it‘s always more difficult to properly trim an airplane. I also trim much more in the sim than in rl for that reason.

Not had much time in SU5 as have been on holiday "in a real plane :slight_smile: ", but trim is broken in “some” aircraft for me, so not a binding issue else wouldn’t it be all? For instance the ICON trim does nothing for me. Will try out some more later.

R U sure it’s broken on the Icon?
It’s very slow and I need ~5sec for the bar on the trim indicator to move to the next bar.

I’ve got a X56-Hotas analog wheel set for trim that has always worked perfectly pre SU5. Can see it working in the controller setup, and it works perfectly still for some aircraft. For the ICON last night it appeared to be doing nothing. I’ll try again later to see if its…slow?

I’ve only flown the 172, BN2 Islander, and JF Turbo Arrow so far, and I have no issues with trim either. I’m using the trim wheel on a Logitech mutli-panel so never see those acceleration issues I have read about when you hold a button down. The wheel acts as if you are rapidly pressing a button, rather than holding it down.

The acceleration issue has luckily been fixed since SU5 (or even SU4)

1 Like

C172 S (Steam Gauge) trim works for me. Yes it is sensitive, but so is trim in general in MSFS. I compensate with dialing down my trim wheel sensitivity of my Thrustmaster TCS (16000m). Hope this helps some:

It may not be an issue if you’re using an axis, but the issue is that using a physical trim wheel with the C172S now acts as a button instead of a wheel control like it used to and still does in the C172 G1000. You can hear the clicks as you adjust the wheel - the same sounds as if you use the electric trim switches.

Electric trim does work, but it’s very hard to fine tune, as each “click” of the trim control is huge. Using the trim wheel is just a terrible pain. Personally for that plane, I would much prefer use the wheel, as it allows for more accurate trim. Well, it used to until Asobo broke it.

1 Like

I get it, when you either click on the trim wheel to move it or use the keyboard. I can see that as it is quite sensitive and only by reducing my axis travel by 50% made it workable.

Fair enough, I did not try this as I always used that assigned axis.

I agree it can certainly be improved.

Correct…in RL …Climb out…Attitude…Power…Trim…until the stick can be let go
Much easier than it is in the Sim.

I also meet this issue, but just the pitch trim works uncontrolled, aeroplane just equipped with elevator trim works correct. Like X Cub, DA62 which equipped with pitch trim always moves automatically, and i even can’t cut off auto pitch trim or adjust the pitch trim.

Don’t understand. On e.g. the DA62 the elevator is being used for trimming and e.g. on the 787 the horizontal stabilizer.
Both, elevator and stabilizer trimming are called pitch trim.

If trim is moving on its own (with the AP OFF), it’s likely that there’s some kind of assistence active.

Yes since SU5 the trim is very broken on many aircraft and it doesn’t matter which controller I use. One quick click of up or down trim causes either 1000ft/min climb or 1000ft/min descent. I made a custom trim wheel using an Arduino because SU5 broke the trim.

I’ve noticed it instantly after SU5 because I almost nose dived when trimming during initial climb.

The problem isn’t with Trim Axis, only trim using buttons.

That is exactly the problem👍

As I said, the trim wheel on the Logitech panel isn’t actually an axis.

Trim works fine here

DON’T write that it works…your post will get flagged in no time.