TRIM issue still not fixed since SU5?

It’s ok.I am used to it. :joy:
I also have been silenced 2 times from 7 days each.


Have you flown the steam gauge C172 since SU5?

1 Like

Nope clean install with no mods

Just tested the classic 172. Cruising at ~110kias,1 trim click results in very small pitch changes and the speed stabilizes ~2kts above/below the previous speed.
Doesn’t look too bad to me, although a tad on the sensitive side.

Are you using a trim wheel or electric trim via buttons?

Is that on the keyboard Num 7 and Num 1 or on a flightstick ?

Joystick button.

The main issue is with using trim wheels.

Now that said, I haven’t flown it since the hotfixes landed, so they may have improved the electric trim (via buttons) . But the issue still exists for those using a wheel.

1 Like

The usual trim wheels (like the one on the Bravo Throttle) works via buttons too, just like a joystick button. It‘s just quite sensitive as small movements may trigger more than one „button presses“. The difference is that you can hold a trim button down while you quickly hit a button repeatedly when you turn the wheel.

No problems here either, however I assigned everything using Axisandohs. No sim internal bindings anymore.

1 Like

Yes it was broken for C172 Steam. I had the same issue, Trim was either full on or full off with Honeycomb Alpha after the SU5 update. G1000 ones were fine!

BUT!!! this was due to not having the game updated with the latest optional update for the Deluxe package. Something I had to search for as it didnt come up as required.

Go to your Marketplace, then to Content Manager and search for Updates, after updating it should work.

Unless the trim changes based on the setting of the sensitivity of the joystick.

Try using a flat sensitivity curve and see if that fixes your problem.

I have zero issues with trim on my end, other than they reversed the direction of the axis, which is no big deal. It may also be possible they decided to forget my setting at update time, so it only seemed to me that I had to reverse it.

I’m using buttons for my trim and this update was a big improvement for me.

Using Saitek X52 controllers

Same issue. When using a joystick button as trim, it translates to ± 600fpm. But it is already a known problem. There are numerous threads in the bug section where you can vote.

600fpm? Which aircraft and at what speed?
On the 172 at 110kts it’s between 100-200fpm.

I flew the CRJ today and the trim was badly broken on my Thrustmaster HOTAS. I use the analog dial and it was giving me a trim range of about 10% around where ever it was centred rather than 100% range like it used to. The plane was pretty much unflyable.

Please fix Asobo.

Been hearing the clicks and yes it adjusts too much.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.