Troubleshooting scenery stutters on high-end hardware (RTX 4090 / 5900X / Reverb G2)

What you’re describing for the HTC is what is generally referred to as “motion reprojection” or MR, as it’s called in WMR for the G2, or ASW for Quest 2. This function is very well known. Some use it for the same reasons you do. Others can’t stand the “wobbling”, what you refer to as “the little aquatic dance”. :slight_smile:

1 Like

Forgive my lack of knowledge with the terms, I do not know if it is exactly the same, because that option you describe is in the graphics options of the simulator and for me that option does not affect my performance, but the VIVE Console option does for good. In the simulation I hardly notice that wobble, in fact it disappears completely when I’ve been playing for a few minutes, I only notice it in the menus, but my experience has improved a lot, before it was impossible to have a decent experience in VR, even with a powerful computer like mine and lowering all the graphic parameters, now I’m really enjoying the experience. :blush:

1 Like

I think it is. I had forgotten about the option within MSFS itself as I never use it. All these differently named functions do the same thing: calculating and inserting frames in between “real” frames to get a refresh rate that’s a multiple of the frame rate.

And I do understand and appreciate your enthusiasm and happiness with your discovery. I am in the pro MR camp myself. In fact, on my Quest 2 and lowly 3060 Ti I simply have to use it, despite the wobbly menus. And I use the rather counter-intuitive setting of ASW18 on 120 Hz, so I fix my fps at 24 Hz with 4 frames being interpolated for each single real one. You would think: how can that possibly look good, but it feels smoother than 72 Hz at ASW30 to me, which would also be 24 fps.

And I agree with you that in-game, I don’t notice the wobbling and artefacts that much, at least they don’t overly disturb me. The thing is, there’s no alternative for me. Not using MR is more immersion-breaking than using it with my system. :slight_smile:

1 Like

I read somewhere (maybe on this thread) that the wobbles with MR have got worse of late, even with a high end system. I have been able to run MR set at 45fps with my 4090/5800X3D rig, but today just flying gliders in a rural setting, the MR wobbles were terrible. Sitting on the grass after a flight with the canopy open the horizon was wobbling like crazy for no reason, as i wasn’t moving. I tried canning DLSS Quality for TAA and it was still there. It was so bad that later flying the Ant’s Tiger Moth I closed the sim, disabled the toolkit, switched off MR restarted and set DLSS at performance which of course got rid of the MR wobbles. Things were nice and sharp (OXR at 160%) and my framerates were mostly over 90fps using a G2 headset, up to 95 fps in fact.

So, no reason for stutters one would think, but the scenery looking down was stuttering very noticeably. Maybe server issues or something in the latest beta, which I am on? Who knows.

The only thing I can think of is if you use shake reduction in OXRTK with MR you can get very bad wobbles. If so, try turning shake reduction off.

Thanks for the suggestion, but I had shake reduction set to zero. From what I have read about stutters on the beta threads, there could be issues with the current release or it could just be sim Gremlins. Time will tell.

So much to read and understand…. For me at least, stopping holographicshell does it! I9-12900, RTX2070, 32GB with few stutters now: at 1000 ft from EGLC rwy27 in a P28A. Smooth with only 22 FPS, so will need to experiment further with graphic settings. Thank everybody for posting thoughts and solutions.

I kill the holographicshell in my starting .bat file, so that’s not the one for me. It may have been worse with it though…

Just an observation, but sitting as still as possible and staring at the open ATC window with MR enabled, the wobbles do in fact seem to come at regular pulses, seemingly in time with my heartbeat. I’ve just tried this in the menu screen too. Is anyone able to confirm this?

When I had Win11 installed (I’m back on Win10 now) there was of course the oversensitive headset tracking issue, picking up my heartbear, which the toolkit has the option to mitigate.

I’m trying to see if the wobbles stop with the headset sitting on the desk, but it’s hard to get an eyeball in there…

Have you tried turning off all frame limiters, lowering settings a lot, and flying in a rural area to see if its still happening?

I have the same setup as you (5800X3D and RTX 4090) and had the same problem with DLSS.
When looking at the FPS counter in VR from OpenXR toolkit you’ll notice the the main thread is limited (CPU bound)
My frame times are constantly between 19 en 27 ms : It looks like the 5800X3D is just not strong enough to keep up with the 4090.

After a lot tickering I just turn it to TAA, grafics are better and the stuttering went from very annoying to micro stutters.
Currently I’m getting between 37 FPS above big Cities (Seatlle, New York etc) to 48/50 above less dense area’s
(This is while using a lot of add-ons and FSLTL for AI traffic)

This is mind boggling to me, because TAA is a huge performance hit vs DLSS. So much so, it’s the reason I scrapped TAA and went with 200% OXR and DLSS Quality, better clarity and performance to boot.

Man sometimes I wonder what it would be like if we got everybody in these VR forums in one big expo center and we all got to walk around and try each other’s setups/tweaks. There would be a competition where everybody voted for the “best” and then a winner would be declared. Then we would cannibalize the winner’s entire system from top to bottom to duplicate each and every setting so we could establish a solid baseline. lol

1 Like